httpd-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From field...@apache.org
Subject svn commit: r572417 - /httpd/httpd/branches/2.2.x/STATUS
Date Mon, 03 Sep 2007 20:32:29 GMT
Author: fielding
Date: Mon Sep  3 13:32:28 2007
New Revision: 572417

URL: http://svn.apache.org/viewvc?rev=572417&view=rev
Log:
vote, promote, and demote

Modified:
    httpd/httpd/branches/2.2.x/STATUS

Modified: httpd/httpd/branches/2.2.x/STATUS
URL: http://svn.apache.org/viewvc/httpd/httpd/branches/2.2.x/STATUS?rev=572417&r1=572416&r2=572417&view=diff
==============================================================================
--- httpd/httpd/branches/2.2.x/STATUS (original)
+++ httpd/httpd/branches/2.2.x/STATUS Mon Sep  3 13:32:28 2007
@@ -79,39 +79,33 @@
 PATCHES ACCEPTED TO BACKPORT FROM TRUNK:
   [ start all new proposals below, under PATCHES PROPOSED. ]
 
+    * mod_proxy: Improve network performance by setting APR_TCP_NODELAY
+     (disable Nagle algorithm) on sockets if implemented. PR 42871.
+      Trunk version of patch:
+         http://svn.apache.org/viewcvs.cgi?rev=562510&view=rev
+      Backport version for 2.2.x of patch:
+         Trunk version of patch works
+      +1: rpluem, jim, fielding
 
-PATCHES PROPOSED TO BACKPORT FROM TRUNK:
+    * mod_proxy: Ensure that at least scheme://hostname[:port] matches
+      between worker and URL when trying to find the worker that fits best to
+      the given URL. PR 40910.
+      Trunk version of patch:
+         http://svn.apache.org/viewcvs.cgi?rev=481901&view=rev
+      Backport version for 2.2.x of patch:
+         Trunk version of patch works
+      +1: rpluem, jim, fielding
 
-    * mpm_winnt: Fix return values from wait_for_many_objects.
-      Note - this is required to avoid hangups of socket #64, #128
-      as Microsoft set aside 64 reserved values.
+   * mod_proxy_http: make proxy-sendchunked work as documented.
+     PR 43183
       Trunk version of patch:
-        http://svn.apache.org/viewvc?view=rev&revision=428029
-      2.2.x version of patch:
-        Trunk version works
-        http://people.apache.org/~wrowe/mpm_winnt_waits.patch
-        is easier to read (-U8)
-      +1: mturk
-      +0: fielding (patch is okay, underlying code is crap)
-      wrowe notes: a patch should have the necessary effect with the
-        minimum lines of code - there's alot of redecorating that's
-        going on in this patch to no net effect.  The WAIT_TIMEOUT
-        result value seems to be ignored in the revised code?
-      mturk notes: WAIT_TIMEOUT is replaced by WAIT_FAILED with
-        the accompanied patch in mpm\winnt\child.c.
-      fielding notes: the routine is brain-dead -- one cannot replicate
-        a wait for many objects by iterating through multiple waits with
-        a one second sleep in between loops.  That's insane.
-        The right ways to do that are explained in the MSDN article
-        <http://msdn2.microsoft.com/en-us/library/ms687025.aspx>
-        In any case, it should be checking nCount <= MAXIMUM_WAIT_OBJECTS
-        first and use the simple wait in that case.
-      mturk notes: We are interested in that only during shutdown
-        so a one second simplification is acceptable compromise.
-        The sole purpose of the patch is to allow the clean shutdown
-        when the MaxClients is higher then 257. 
-      wrowe: conditional +1 if you rename the assanine function name
-        so no one confuses it for its implied purpose.
+         http://svn.apache.org/viewcvs.cgi?rev=572000&view=rev
+      2.2 version: noodl's patch at
+         http://issues.apache.org/bugzilla/attachment.cgi?id=20699
+     +1: niq, rpluem, fielding
+
+
+PATCHES PROPOSED TO BACKPORT FROM TRUNK:
 
    * mod_authn_dbd: Export any additional columns queried in the SQL select
      into the environment with the name AUTHENTICATE_<COLUMN>. This brings
@@ -125,17 +119,6 @@
                   Without r571838 the documentation for mod_authn_dbd fails
                   to build.
 
-   * beos MPM: Create pmain pool and run modules' child_init hooks when
-     entering ap_mpm_run(), then destroy pmain when exiting ap_mpm_run().
-     Otherwise modules' child_init hooks appear to never be executed.
-     Also, destroying pmain ensures that cleanups registered in modules'
-     child_init hooks are performed (e.g., mod_log_config and mod_dbd).
-     Trunk version of patch:
-       http://svn.apache.org/viewvc?view=rev&revision=491922
-     2.2.x version of patch:
-       http://people.apache.org/~chrisd/patches/mod_dbd_pools_groups/mpm_child_init-beos-2.2.x.patch
-     +0: chrisd (abstaining; unable to test)
-
     * multiple files,	Trivial cleanups
       PR: 39518 - Christophe JAILLET
       http://svn.apache.org/viewvc?view=rev&revision=557837
@@ -145,31 +128,6 @@
       +1 for core, modules/dav, modules/filters, and modules/ssl
       Not Applicable to modules/aaa
 
-    * mod_ldap, mod_authnzldap: Add support for nested groups (i.e. the ability
-      to authorize an authenticated user via a "require ldap-group X" directive
-      where the user is not in group X, but is in a subgroup contained in X.
-      PR: 42891
-      http://svn.apache.org/viewvc?view=rev&revision=560373
-      http://svn.apache.org/viewvc?view=rev&revision=562165
-      A version of the patch specific to the 2.2 branch (i.e. the patch that
-      would be used for backport) can be found at:
-      http://people.apache.org/~rederpj/NestedGroups_2.2.xBranch.diff 
-      +1: rederpj
-      -0: bnicholes - Unless this is considered to be a significant deficiency in the
-                       authnz_ldap 2.2 functionality, I would rather see this as new
-		       functionality going forward in 2.4 rather than backported to
-		       2.2. We need new functionality to push us forward rather than
-		       give us an excuse to stay where we are.
-      rederpj says: I'm working on a project based on Apache 2.2.x which needs this code
-          and I would much prefer to use official Apache code than end up using a private
-          patch. It isn't possible in the short term for us to move to trunk. It just
-          happened that code I had written to add this function lined up with PR 42891.
-          I was going to submit it and work to get it backported either way.
-      rpluem says: I am still missing a minor bump due to the changes done
-      in util_ldap.h. This is an extension of a public API.
-      trawick says: The new directives should be documented in trunk,
-          so that docs are available for backport at the same time.
-
    * mod_include: Add an "if" directive syntax to test whether an URL
      is accessible, and if so, conditionally display content. This
      allows a webmaster to hide a link to a private page when the user
@@ -179,30 +137,13 @@
      http://svn.apache.org/viewvc?view=rev&revision=572136
      +1: minfrin
 
-    * mod_proxy: Improve network performance by setting APR_TCP_NODELAY
-     (disable Nagle algorithm) on sockets if implemented. PR 42871.
-      Trunk version of patch:
-         http://svn.apache.org/viewcvs.cgi?rev=562510&view=rev
-      Backport version for 2.2.x of patch:
-         Trunk version of patch works
-      +1: rpluem, jim
-
-    * mod_proxy: Ensure that at least scheme://hostname[:port] matches
-      between worker and URL when trying to find the worker that fits best to
-      the given URL. PR 40910.
-      Trunk version of patch:
-         http://svn.apache.org/viewcvs.cgi?rev=481901&view=rev
-      Backport version for 2.2.x of patch:
-         Trunk version of patch works
-      +1: rpluem, jim
-
     * mod_cache: Remove expired content from cache that cannot be revalidated.
       PR 30370.
       Trunk version of patch:
          http://svn.apache.org/viewcvs.cgi?rev=481886&view=rev
       Backport version for 2.2.x of patch:
          Trunk version of patch works
-      +1: rpluem
+      +1: rpluem, fielding
 
     * mod_mem_cache: Increase the minimum and default value for
       MCacheMinObjectSize from 0 to 1, as a MCacheMinObjectSize of 0 does
@@ -212,7 +153,7 @@
          http://svn.apache.org/viewcvs.cgi?rev=469895&view=rev
       Backport version for 2.2.x of patch:
          Trunk version of patch works
-      +1: rpluem
+      +1: rpluem, fielding
 
     * mod_ssl: Fix spurious hostname-mismatch warning for valid wildcard certs.
       PR 37911.
@@ -220,7 +161,7 @@
          http://svn.apache.org/viewcvs.cgi?rev=378487&view=rev
       Backport version for 2.2.x of patch:
          Trunk version of patch works
-      +1: rpluem
+      +1: rpluem, fielding
 
     * mod_info: mod_info outputs invalid XHTML 1.0 Transitional.
       PR 42847.
@@ -228,17 +169,76 @@
          http://svn.apache.org/viewcvs.cgi?rev=562503&view=rev
       Backport version for 2.2.x of patch:
          Trunk version of patch works
-      +1: rpluem
+      +1: rpluem, fielding
 
-   * mod_proxy_http: make proxy-sendchunked work as documented.
-     PR 43183
+PATCHES/ISSUES THAT ARE STALLED
+
+    * mod_ldap, mod_authnzldap: Add support for nested groups (i.e. the ability
+      to authorize an authenticated user via a "require ldap-group X" directive
+      where the user is not in group X, but is in a subgroup contained in X.
+      PR: 42891
+      http://svn.apache.org/viewvc?view=rev&revision=560373
+      http://svn.apache.org/viewvc?view=rev&revision=562165
+      A version of the patch specific to the 2.2 branch (i.e. the patch that
+      would be used for backport) can be found at:
+      http://people.apache.org/~rederpj/NestedGroups_2.2.xBranch.diff 
+      +1: rederpj
+      -0: bnicholes - Unless this is considered to be a significant deficiency in the
+                       authnz_ldap 2.2 functionality, I would rather see this as new
+		       functionality going forward in 2.4 rather than backported to
+		       2.2. We need new functionality to push us forward rather than
+		       give us an excuse to stay where we are.
+      rederpj says: I'm working on a project based on Apache 2.2.x which needs this code
+          and I would much prefer to use official Apache code than end up using a private
+          patch. It isn't possible in the short term for us to move to trunk. It just
+          happened that code I had written to add this function lined up with PR 42891.
+          I was going to submit it and work to get it backported either way.
+      rpluem says: I am still missing a minor bump due to the changes done
+      in util_ldap.h. This is an extension of a public API.
+      trawick says: The new directives should be documented in trunk,
+          so that docs are available for backport at the same time.
+
+    * mpm_winnt: Fix return values from wait_for_many_objects.
+      Note - this is required to avoid hangups of socket #64, #128
+      as Microsoft set aside 64 reserved values.
       Trunk version of patch:
-         http://svn.apache.org/viewcvs.cgi?rev=572000&view=rev
-      2.2 version: noodl's patch at
-         http://issues.apache.org/bugzilla/attachment.cgi?id=20699
-     +1: niq, rpluem
+        http://svn.apache.org/viewvc?view=rev&revision=428029
+      2.2.x version of patch:
+        Trunk version works
+        http://people.apache.org/~wrowe/mpm_winnt_waits.patch
+        is easier to read (-U8)
+      +1: mturk
+      +0: fielding (patch is okay, underlying code is crap)
+      wrowe notes: a patch should have the necessary effect with the
+        minimum lines of code - there's alot of redecorating that's
+        going on in this patch to no net effect.  The WAIT_TIMEOUT
+        result value seems to be ignored in the revised code?
+      mturk notes: WAIT_TIMEOUT is replaced by WAIT_FAILED with
+        the accompanied patch in mpm\winnt\child.c.
+      fielding notes: the routine is brain-dead -- one cannot replicate
+        a wait for many objects by iterating through multiple waits with
+        a one second sleep in between loops.  That's insane.
+        The right ways to do that are explained in the MSDN article
+        <http://msdn2.microsoft.com/en-us/library/ms687025.aspx>
+        In any case, it should be checking nCount <= MAXIMUM_WAIT_OBJECTS
+        first and use the simple wait in that case.
+      mturk notes: We are interested in that only during shutdown
+        so a one second simplification is acceptable compromise.
+        The sole purpose of the patch is to allow the clean shutdown
+        when the MaxClients is higher then 257. 
+      wrowe: conditional +1 if you rename the assanine function name
+        so no one confuses it for its implied purpose.
 
-PATCHES/ISSUES THAT ARE STALLED
+   * beos MPM: Create pmain pool and run modules' child_init hooks when
+     entering ap_mpm_run(), then destroy pmain when exiting ap_mpm_run().
+     Otherwise modules' child_init hooks appear to never be executed.
+     Also, destroying pmain ensures that cleanups registered in modules'
+     child_init hooks are performed (e.g., mod_log_config and mod_dbd).
+     Trunk version of patch:
+       http://svn.apache.org/viewvc?view=rev&revision=491922
+     2.2.x version of patch:
+       http://people.apache.org/~chrisd/patches/mod_dbd_pools_groups/mpm_child_init-beos-2.2.x.patch
+     +0: chrisd (abstaining; unable to test)
 
     * PKCS#7: backport PCKS#7 patches from trunk.
       +1 ben



Mime
View raw message