httpd-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wr...@apache.org
Subject svn commit: r413144 - /httpd/site/trunk/docs/download.html
Date Fri, 09 Jun 2006 20:00:03 GMT
Author: wrowe
Date: Fri Jun  9 13:00:03 2006
New Revision: 413144

URL: http://svn.apache.org/viewvc?rev=413144&view=rev
Log:

  * Add 2.2.2 win32 files
  * Recover 2.0.58 win32 files
  * Remoove 1.3 win32 files

  * Ensure it is clear - each Apache modules are incompatible with one
    another (reassure 2.2 users their effort isn't wasted)

  * Clarify 2.0 that this is the stable release

  * Stop calling 1.3 a best version / it's a stable release, stop promising
    some future update that might, or might not, ever be made.  Leave it that
    sometimes security holes or bugs are fixed.

Modified:
    httpd/site/trunk/docs/download.html

Modified: httpd/site/trunk/docs/download.html
URL: http://svn.apache.org/viewvc/httpd/site/trunk/docs/download.html?rev=413144&r1=413143&r2=413144&view=diff
==============================================================================
--- httpd/site/trunk/docs/download.html (original)
+++ httpd/site/trunk/docs/download.html Fri Jun  9 13:00:03 2006
@@ -118,9 +118,10 @@
 <p>For details see the <a href="http://www.apache.org/dist/httpd/Announcement2.2.html">Official
    Announcement</a> and the <a href="[preferred]/httpd/CHANGES_2.2">CHANGES_2.2</a>
list.</p>
 <p>Apache 2.2 add-in modules are not compatible with Apache 2.0 or 1.3 modules.
-   If you are running third party add-in modules, you will need to obtain
-   new modules written for Apache 2.2 from that third party before you
-   attempt to upgrade from Apache 2.0.</p>
+   If you are running third party add-in modules, you must obtain modules
+   compilied or updated for Apache 2.2 from that third party, before you
+   attempt to upgrade from any previous version of Apache.  Modules compiled
+   for Apache 2.2 should continue to work for all 2.2.x releases.</p>
 <ul>
 
 <li>Unix Source: 
@@ -135,6 +136,18 @@
 [<a href="http://www.apache.org/dist/httpd/httpd-2.2.2.tar.bz2.md5">MD5</a>]
 </li>
 
+<li>Win32 Source: 
+<a href="[preferred]/httpd/httpd-2.2.2-win32-src.zip">httpd-2.2.2-win32-src.zip</a>

+[<a href="http://www.apache.org/dist/httpd/httpd-2.2.2-win32-src.zip.asc">PGP</a>]
+[<a href="http://www.apache.org/dist/httpd/httpd-2.2.2-win32-src.zip.md5">MD5</a>]
+</li>
+
+<li>Win32 Binary (MSI Installer): 
+<a href="[preferred]/httpd/binaries/win32/apache_2.2.2-win32-x86-no_ssl.msi">apache_2.2.2-win32-x86-no_ssl.msi</a>
+[<a href="http://www.apache.org/dist/httpd/binaries/win32/apache_2.2.2-win32-x86-no_ssl.msi.asc">PGP</a>]
+[<a href="http://www.apache.org/dist/httpd/binaries/win32/apache_2.2.2-win32-x86-no_ssl.msi.md5">MD5</a>]
+</li>
+
 <li><a href="[preferred]/httpd/">Other files</a></li>
 
 </ul>
@@ -150,12 +163,15 @@
  </td></tr>
  <tr><td>
   <blockquote>
+<p>Apache 2.0.58 is the current stable version of the 2.0 series, and
+is recommended over any previous 2.0 release.  This release fixes a number
+of bugs in pervious 2.0 versions.</p>
 <p>For details see the <a href="http://www.apache.org/dist/httpd/Announcement2.0.html">Official
    Announcement</a> and the <a href="[preferred]/httpd/CHANGES_2.0">CHANGES_2.0</a>
list.</p>
-<p>Apache 2.0 add-in modules are not compatible with Apache 1.3 modules.
+<p>Apache 2.0 add-in modules are not compatible with Apache 1.3 nor 2.2 modules.
    If you are running third party add-in modules, you will need to obtain
-   new modules written for Apache 2.0 from that third party before you
-   attempt to upgrade from Apache 1.3.</p>
+   modules compiled for or compatible with Apache 2.0 from that third party,
+   before you attempt to use this specific release.</p>
 <ul>
 
 <li>Unix Source: 
@@ -170,22 +186,17 @@
 [<a href="http://www.apache.org/dist/httpd/httpd-2.0.58.tar.bz2.md5">MD5</a>]
 </li>
 
-<!--
 <li>Win32 Source: 
-<a href="[preferred]/httpd/httpd-2.0.58-win32-src.zip"
-  >httpd-2.0.58-win32-src.zip</a> 
+<a href="[preferred]/httpd/httpd-2.0.58-win32-src.zip">httpd-2.0.58-win32-src.zip</a>

 [<a href="http://www.apache.org/dist/httpd/httpd-2.0.58-win32-src.zip.asc">PGP</a>]
 [<a href="http://www.apache.org/dist/httpd/httpd-2.0.58-win32-src.zip.md5">MD5</a>]
 </li>
 
-
 <li>Win32 Binary (MSI Installer): 
-<a href="[preferred]/httpd/binaries/win32/apache_2.0.58-win32-x86-no_ssl.msi"
-  >apache_2.0.58-win32-x86-no_ssl.msi</a>
+<a href="[preferred]/httpd/binaries/win32/apache_2.0.58-win32-x86-no_ssl.msi">apache_2.0.58-win32-x86-no_ssl.msi</a>
 [<a href="http://www.apache.org/dist/httpd/binaries/win32/apache_2.0.58-win32-x86-no_ssl.msi.asc">PGP</a>]
 [<a href="http://www.apache.org/dist/httpd/binaries/win32/apache_2.0.58-win32-x86-no_ssl.msi.md5">MD5</a>]
 </li>
--->
 
 <li><a href="[preferred]/httpd/">Other files</a></li>
 
@@ -201,29 +212,25 @@
  </td></tr>
  <tr><td>
   <blockquote>
-<p>Apache 1.3.36 is the best available version of the 1.3 series, and
-is recommended over all previous 1.3 releases.  This release fixes
-an unexpected and unwanted regression introduced in 1.3.35.</p>
+<p>Apache 1.3.36 is the current stable version of the 1.3 series, and
+is recommended over any previous 1.3 release.  This release fixes
+several regressions introduced in 1.3.35 that interfered with Include'ing 
+other configuration files from the main httpd.conf configuration file.</p>
 <p>For additional details, read the <a href="http://www.apache.org/dist/httpd/Announcement1.3.html">Official
 Announcement</a>.</p>
-<p>The Apache 1.3 series is being actively maintained, and 
-developed at a leisurely pace, to maintain stability. Releases will be made to address security
issues, or after
-a comfortable number of bug fixes or improvements have been made.
-Significantly new features are unlikely to be added to 1.3
-in preference to 2.0, although important new features and
-enhancements will be seriously considered for inclusion in 1.3.</p>
-<p>Use the Apache 1.3.36 version if you need to use third party
-modules that are not yet available as an Apache 2.x module.  Apache
-1.3 is not compatibile with Apache 2.x modules.</p>
+<p>The Apache 1.3 series is no longer under development.  Releases
+are occasionally created to address security issues, or after a number 
+of bugs are fixed.  New features are not likely to be added to 1.3.</p>
+<p>Use the Apache 1.3.36 version only if you must use a third party module
+that is not available as an Apache 2.x module.  Modules compiled for Apache 2.x
+are not compatible with Apache 1.3, and modules compiled for Apache 1.3 are
+not compatible with Apache 2.x.</p>
 <ul>
 <li>Unix Source: <a href="[preferred]/httpd/apache_1.3.36.tar.gz">apache_1.3.36.tar.gz</a>
 [<a href="http://www.apache.org/dist/httpd/apache_1.3.36.tar.gz.asc">PGP</a>]
[<a href="http://www.apache.org/dist/httpd/apache_1.3.36.tar.gz.md5">MD5</a>]</li>
 
 <li>Unix Source: <a href="[preferred]/httpd/apache_1.3.36.tar.Z">apache_1.3.36.tar.Z</a>
 [<a href="http://www.apache.org/dist/httpd/apache_1.3.36.tar.Z.asc">PGP</a>]
[<a href="http://www.apache.org/dist/httpd/apache_1.3.36.tar.Z.md5">MD5</a>]</li>
-
-<li>Win32 Binary (Self extracting): <a href="[preferred]/httpd/binaries/win32/apache_1.3.36-win32-x86-no_src.exe">apache_1.3.36-win32-x86-no_src.exe</a>
[<a href="http://www.apache.org/dist/httpd/binaries/win32/apache_1.3.36-win32-x86-no_src.exe.asc">PGP</a>]
-[<a href="http://www.apache.org/dist/httpd/binaries/win32/apache_1.3.36-win32-x86-no_src.exe.md5">MD5</a>]</li>
 
 <li><a href="[preferred]/httpd/">Other files</a></li>
 </ul>



Mime
View raw message