httpd-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jor...@apache.org
Subject svn commit: r331606 - in /httpd/httpd/branches/2.2.x: CHANGES configure.in
Date Mon, 07 Nov 2005 21:54:32 GMT
Author: jorton
Date: Mon Nov  7 13:54:29 2005
New Revision: 331606

URL: http://svn.apache.org/viewcvs?rev=331606&view=rev
Log:
Merge r328641, r328852 from trunk:

* configure.in: Require apr >= 1.2.0 and apr-util >= 1.2.0.

* configure.in: Move apr/apr-util version checks later to fix in-tree
apr/apr-util build failures due to $EGREP not getting set early
enough.


Modified:
    httpd/httpd/branches/2.2.x/CHANGES
    httpd/httpd/branches/2.2.x/configure.in

Modified: httpd/httpd/branches/2.2.x/CHANGES
URL: http://svn.apache.org/viewcvs/httpd/httpd/branches/2.2.x/CHANGES?rev=331606&r1=331605&r2=331606&view=diff
==============================================================================
--- httpd/httpd/branches/2.2.x/CHANGES [utf-8] (original)
+++ httpd/httpd/branches/2.2.x/CHANGES [utf-8] Mon Nov  7 13:54:29 2005
@@ -1,6 +1,9 @@
                                                         -*- coding: utf-8 -*-
 Changes with Apache 2.1.10
 
+  *) Require use of APR >= 1.2.0 and APR-util >= 1.2.0 when configured 
+     to use external copies of the libraries.  [Joe Orton] 
+
   *) Fix DESTDIR=... installation when using bundled copy of APR.
      [Torsten Foertsch <torsten.foertsch gmx.net>]
 

Modified: httpd/httpd/branches/2.2.x/configure.in
URL: http://svn.apache.org/viewcvs/httpd/httpd/branches/2.2.x/configure.in?rev=331606&r1=331605&r2=331606&view=diff
==============================================================================
--- httpd/httpd/branches/2.2.x/configure.in (original)
+++ httpd/httpd/branches/2.2.x/configure.in Mon Nov  7 13:54:29 2005
@@ -314,6 +314,18 @@
 AC_ISC_POSIX
 AC_MINIX
 
+# Ensure that satisfactory versions of apr and apr-util are 
+# found if external copies are configured.
+if test "${apr_found}" = "yes"; then
+  # Require APR 1.2.x otherwise fail
+  APACHE_CHECK_APxVER([apr], 1, 2)
+fi
+
+if test "${apu_found}" = "yes"; then
+  # Require APR-util 1.2.x otherwise fail
+  APACHE_CHECK_APxVER([apu], 1, 2)
+fi
+
 dnl Check for what we can generate dependency files with
 APR_CHECK_DEPEND
 



Mime
View raw message