httpd-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Querna <c...@force-elite.com>
Subject Re: svn commit: r169705 - in /httpd/httpd/trunk: include/util_ldap.h modules/ldap/util_ldap.c
Date Wed, 11 May 2005 22:52:23 GMT
bnicholes@apache.org wrote:
> Author: bnicholes
> Date: Wed May 11 15:34:18 2005
> New Revision: 169705
> 
> URL: http://svn.apache.org/viewcvs?rev=169705&view=rev
> Log:
> Add the LDAPVerifyServerCert directive to util_ldap to force
> verification of a server certificate when establishing an SSL connection
> to the LDAP server
> 
> Modified:
>     httpd/httpd/trunk/include/util_ldap.h
>     httpd/httpd/trunk/modules/ldap/util_ldap.c
> 


Ack.  This commit means that httpd/trunk now depends on apr-util/trunk.
 Before this you were able to run httpd/trunk using APR-Util 1.1.x.

This effectively kills any httpd alphas until APR-Util 1.2.0 is released.

I believe we should uphold the policy of using only released versions of
a dependency.

I don't see an APR-Util 1.2.0 coming very soon. The APR-DBD code could
still use more love.

This is just an example of why I wanted to branch trunk to 2.1.x.  I
have nothing against adding this specific feature  -- it just happens to
require a non-released version of APR-Util.

Ideas for a solution that doesn't involve waiting for APR-Util 1.2.0?

Thanks,

-Paul

Mime
View raw message