httpd-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From c...@hyperreal.org
Subject cvs commit: apache-1.3 STATUS
Date Wed, 08 Apr 1998 10:34:05 GMT
coar        98/04/08 03:34:05

  Modified:    .        STATUS
  Log:
  	Votes, minor mods, veto removed.
  
  Revision  Changes    Path
  1.278     +8 -21     apache-1.3/STATUS
  
  Index: STATUS
  ===================================================================
  RCS file: /export/home/cvs/apache-1.3/STATUS,v
  retrieving revision 1.277
  retrieving revision 1.278
  diff -u -r1.277 -r1.278
  --- STATUS	1998/04/08 07:48:43	1.277
  +++ STATUS	1998/04/08 10:34:04	1.278
  @@ -87,6 +87,7 @@
       * back out USE_PTHREAD_SERIALIZED_ACCEPT for solaris
       * Ken's abstraction of SERVER_{BUILT,VERSION}
       * Ken's fix for os/unix/os.h and the new -DHIDE functionality
  +      -- needs to be undone when HIDE is backed out
       * Ralf's Config File Line Continuation
       * Ralf's Reanimation of DBM support for RewriteMap in mod_rewrite PR#1696
       * Ralf's fix for the `<VirtualHost> w/o mod_rewrite' situation. PR#1790
  @@ -127,6 +128,7 @@
       * Ralf's change to make the shared object compilation command more portable
       * Dean's protect against FD_SETSIZE mismatches
       * Ralf's fallback stategy because of HIDE for loading shared object modules
  +      -- does this need to be revisited due to HIDE rollback?
       * Martin's fix to allow %2F chars in proxy requests and in the uri query
         part
       * fix to mark listening sockets for closure in the parent after a SIGHUP 
  @@ -261,13 +263,11 @@
         1.3b6 and thus for the 1.3.x release branch via the
         apache-1.3/src/test/rename/rename.cf file as the configuration for the
         renaming. The used prefix or prefixes are configureable in the file.
  -       +1: Roy, Ralf, Jim, Ken 
  +       +1: Roy, Ralf, Jim
           0: Marc
   
         NOTES:
          - Marc: this is the wrong time for such a big change
  -       - Ken:  only because collisions won't be addressed any
  -               other way, apparently - otherwise agrees with Marc
          - Ralf: Yes, I personally also would like to keep HIDE, but
                  now because it's vetoed, it's better to rename the
                  source instead of just having the
  @@ -280,16 +280,13 @@
   
           - Public API functions (e.g., palloc)
               ap_xxx:    +1: Ralf, Roy, Dean, Randy, Martin, Brian, Paul
  -            apapi_xxx: +1: Ken
   
           - Private functions which we can't make static (because of
             cross-object usage) but should be (e.g., new_connection)
               ap_xxx:    +1: Roy, Dean, Randy, Martin, Brian, Paul
   	               -0: Ralf
  -		       -1: Ken
               apx_xxx:   +1: Ralf
  -            appri_xxx: +1: Ken
  -	               +0: Ralf
  +            appri_xxx: +0: Ralf
   
           - Public API module structure variables (e.g.,
             status_module) which are used special in Configure,
  @@ -302,16 +299,7 @@
               apm_xxx:   +0: Ralf
   
           Notes: 
  -	    - Ken: I'm vetoing the 'same prefix for everything' proposed
  -	      patch because it means that everything is part of the API, and
  -	      every single change - even to things which aren't supposed
  -	      to be used by modules - will require a bump to MMN.  Either
  -	      we do it right, and distinguish by name between what's for
  -	      public consumption and what's not, or we don't do a global
  -	      rename at this point.  I feel this distinction is necessary
  -	      because of our 'glass house' (full source availability)
  -	      environment.  Saying 'look at the [nonexistent] documentation'
  -	      is a cop-out if we're going to do it right.
  +	    - Ken: Veto rescinded.
   
               - Ralf: My opinion for my decisions are the following ones: 
                 1. The short ap_ prefix is a good idea because its
  @@ -414,8 +402,7 @@
   	-1:  
   
       * What do we call the binary: apache or httpd? Under UNIX
  -      it's httpd, under Win32 it's apache. Maybe rename it
  -      to apache-httpd?
  +      it's httpd, under Win32 it's apache.
   	apache-httpd: Ken +1
           leave it apache: Brian +1, Ralf +1
   
  @@ -455,7 +442,7 @@
   	  field is r->content_languages.  Heck it's not even mentioned in
   	  apache-devsite/mmn.txt when we got content_languages (note the s!).
   	  The proposal is to remove r->content_language:
  -	    Status: Dean +1, Paul +1, Roy +1, Ralf +1
  +	    Status: Dean +1, Paul +1, Roy +1, Ralf +1, Ken +1
   
   	- child_exit() is redundant, it can be implemented via cleanups.  It is
   	  not "symmetric" in the sense that there is no exit API method to go
  @@ -465,7 +452,7 @@
   	  remove the child_exit() method and document cleanups as the method of
   	  handling this need.
   	    Status: Dean +1, Rasmus +1, Paul +1, Roy +1, Jim +1, 
  -	            Martin +1, Ralf +1
  +	            Martin +1, Ralf +1, Ken +1
   
       * Don't wait for WIN32:  It's been quite some time and WIN32 doesn't seem
   	to be progressing, and Unix seems quite stable.  It would be in Apache's
  
  
  

Mime
View raw message