httpd-cli-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd L Hicks" <electronjoc...@hotmail.com>
Subject RE: [cli-users] Apache and VS.NET 2002 or 2003
Date Mon, 21 Nov 2005 12:16:20 GMT
Richard,
Just a qiuck idea, have you tried creating the share? Unlike IIS w/FPSE,
Apache won't create the share or set the permissions on it.
I had this problem too, and that fixed it for me, even on a remote
Windows/Apache install. It's been a while since I did it, but I'll verify
the configuration.
VS2005 doesn't have this problem because it has it's own web server built in
for the debugging so you don't need to be running one on your workstation
for development. It operates only as part of VS and is not a windows
service.
As for the version problem, check out:
http://issues.apache.org/bugzilla/show_bug.cgi?id=32021
Comment #2 resolved that issue for me using the latest development snapshot.

Regards,
Todd Hicks

-----Original Message-----
From: richard hsu [mailto:richard.hsu@gmail.com] 
Sent: Monday, November 21, 2005 1:06 AM
To: cli-users@httpd.apache.org
Subject: Re: [cli-users] Apache and VS.NET 2002 or 2003

Hi Andreas,

I am not sure about how Apache can be used with VS 2002 but I was in a
similar situation as you recently with when I needed to work on an existing
ASP.NET <http://asp.net/>  project with Visual Studio 2003 on Windows XP
Home. 

I tried out the hack as proposed on www.asp.net <http://www.asp.net/> 's
forum where in you use Cassini Web Server with Visual Studio 2003 and it
worked [although you would have to debug externally with GuiDebug instead].
At that point of time that solved my purpose. I discovered Mod_AspdotNet
later when I needed to host a asp.net <http://asp.net/>  web app from my
home with Windows XP [its perfect for that, thanks guys]. I use WebMatrix
for web applications I write so I didn't try to get Visual Studio 2003,
ASP.NET <http://asp.net/>  and Mod_AspdotNet to work. Sorry.

You can read the hack at http://forums.asp.net/344386/ShowPost.aspx 

Regards,
Richard Hsu,
Toronto, Canada.

[PS. Sorry everyone for the off topic solution, admin can delete this reply
if necessary :-) ]


On 11/20/05, Andy <hp275@skynet.be> wrote:

	Hi,
	
	I'm new here. Please bear with me.
	
	I have a laptop with XP Home. I'm trying to get Visual studio Asp
	dot.net (2002/2003) compiler to run with apache because XP Home
doesn't
	come with a web server. 
	
	So I've successfully installed Apache 2.054 and Mod_AspdotNet with
the
	help of this site :***
	
<http://www.apache.org/dist/httpd/mod_aspdotnet/mod_aspdotnet-2.0.0.msi >***
	http://weblogs.asp.net/israelio/archive/2005/09/11/424852.aspx
	
	I created a directory C:\Toshiba for my web files.
	
	then i added this to  the http.conf :
	
	#ASP.NET
	LoadModule aspdotnet_module modules/mod_aspdotnet.so
	
	AddHandler asp.net asax ascx ashx asmx aspx axd config cs csproj
licx
	rem resources resx soap vb vbproj vsdisco webinfo 
	
	<IfModule mod_aspdotnet.cpp>
	  # Mount the ASP.NET /asp application
	
	  AspNetMount /WebApp "c:/TOSHIBA/WebApp"
	  #/WebApp is the alias name for asp.net <http://asp.net>  to
execute
	  # is the actual execution of files/folders in that location
	  Alias /WebApp "c:/TOSHIBA/WebApp"
	
	  #maps /WebApplication1 request to "c:/TOSHIBA/WebApp"
	  #now to get to the /WebApplication1 type http://localhost/WebApp
	  #It'll redirect http://localhost/WebApplication1 to
"c:/TOSHIBA/WebApp"
	
	  # Allow asp.net <http://asp.net>  scripts to be executed in the
example /WebApplication1
	  <Directory "c:/TOSHIBA/WebApp">
	    Options FollowSymlinks ExecCGI
	    Order allow,deny
	    Allow from all
	    DirectoryIndex index.htm index.aspx
	   #default the index page to .htm and .aspx
	  </Directory>
	
	  # For all virtual ASP.NET webs, we need the aspnet_client files
	  # to serve the client-side helper scripts. 
	  AliasMatch /aspnet_client/system_web/(\d+)_(\d+)_(\d+)_(\d+)/(.*)
	"C:/Windows/Microsoft.NET/Framework/v$1.$2.$3/ASP.NETClientFiles/$4"
	  <Directory
"C:/Windows/Microsoft.NET/Framework/v*/ASP.NETClientFiles"> 
	    Options FollowSymlinks
	    Order allow,deny
	    Allow from all
	  </Directory>
	</IfModule>
	#asp.net
	
	I put an index.aspx file in the c:/TOSHIBA/WebApp directory :
	
	<%@ Page Language="VB" %> 
	<html>
	   <head>
	      <link rel="stylesheet"href="intro.css">
	   </head>
	   <body>
	       <center>
	       <form action="index.aspx" method="post"> 
	           <h3> Name: <input id="Name" type=text>
	           Category:  <select id="Category" size=1>
	                          <option>One</option>
	                          <option>Two</option> 
	                          <option>Three</option>
	                      </select>
	           </h3>
	           <input type=submit value="Lookup">
	           <p>
	           <% Dim I As Integer
	              For I = 0 to 7 %>
	              <font size="<%=I%>"> Sample ASP.NET TEST</font> <br>
	           <% Next %> 
	       </form>
	       </center>
	   </body>
	</html>
	
	Then i started the Apache webserver, surfed to
http://localhost/WebApp
	and it showed the index file all right ! 
	
	But now i wanted to use VisualStudio 2002 : this does not work :
	It says that the UNC share "\\TOSHIBA\wwwroot$\Webapp" does not
exist or
	you do not have access.
	I try to change it to "\\TOSHIBA\toshiba\Webapp", but i get the same
error. 
	
	And with VS 2003 : It complains that the web server runs ASP.NET
1.0,
	which is not true. It asks me either to upgrade the webserver or to
	make the app compliant with 1.1 or not to create the project. 
	
	So i'm stuck with the third option : use Webmatrix, and the move all
	files by hand. not a pleasant prospect.
	
	I haven't tested VS.net 2005
	
	Has anybody gotten VS.NET 2002/03 to work with Apache ? I'd be
really 
	grateful if you could share your experience.
	
	Thanks in advance,
	
	Andreas Vandenberghe
	hp275@removethis.skynet.be
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
---------------------------------------------------------------------
	To unsubscribe, e-mail: cli-users-unsubscribe@httpd.apache.org 
	For additional commands, e-mail: cli-users-help@httpd.apache.org
	
	



---------------------------------------------------------------------
To unsubscribe, e-mail: cli-users-unsubscribe@httpd.apache.org
For additional commands, e-mail: cli-users-help@httpd.apache.org


Mime
View raw message