httpd-cli-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gabriele Bianchini" <g.bianch...@iol.it>
Subject [cli-users] R: [cli-users] mod_aspdotnet and VirtualHost
Date Thu, 21 Jul 2005 16:27:31 GMT
Hello and thanks.

You say to drop the <Directory>...</Directory> directive out of the vhost
section and this make sense to me.
But if I drop the AspNetMount directive out of the vhost section how do I
have to write it so that it maps each request to the correct site?

Following your hint I should write:

<VirtualHost>
	#Site 1 stuff
</VirtualHost>

<VirtualHost>
	#Site 2 stuff
</VirtualHost>

AspNetMount ???what-the-hell-goes-here???? "C:/wwwroot/site-one.it/v4.0"
AspNetMount ???what-the-hell-goes-here???? "C:/wwwroot/site-two.it/v2.0"

I really can't get it...


-----Messaggio originale-----
Da: William A. Rowe, Jr. [mailto:wrowe@rowe-clan.net] 
Inviato: venerdì 15 luglio 2005 23.54
A: cli-users@httpd.apache.org
Oggetto: Re: [cli-users] mod_aspdotnet and VirtualHost

Lets go through your config...

At 02:50 AM 7/14/2005, Gabriele Bianchini wrote:

>NameVirtualHost *:80
> 
><VirtualHost *:80>
>    DocumentRoot "C:/wwwroot"
></VirtualHost>

No servername, so this is the fallback.

> <VirtualHost *:80>
>    DocumentRoot "C:/wwwroot/test1"
>    ServerName test1.local
></VirtualHost>
> 
># -----------------------------------------------------------
># Site 1
># -----------------------------------------------------------
><VirtualHost *:80>
>            ServerName www.site-one.it
>            ServerAlias site-one.it *.site-one.it
>            DocumentRoot "C:/wwwroot/site-one.it/v4.0"

Ok so far...

>             AspNetMount / "C:/wwwroot/site-one.it/v4.0"
> 
>            <Directory "C:/wwwroot/site-one.it/v4.0">
>                        Options FollowSymlinks Indexes Includes ExecCGI
>                        Order allow,deny
>                        Allow from all
>                        DirectoryIndex default.htm default.aspx
>            </Directory>

None of this needs to be in a virtual server.  Although I don't
know if it will help you to 'lift it out' of this context.  The
DocumentRoot maps this server to this mounted app.

></VirtualHost>
> 
># -----------------------------------------------------------
># Site 2
># -----------------------------------------------------------
><VirtualHost *:80>
>            ServerName www.site-two.it
>            ServerAlias site-two.it *.site-two.it
>            DocumentRoot "C:/wwwroot/site-two.it/v2.0"

Ditto my comments above...

>             AspNetMount / "C:/wwwroot/site-two.it/v2.0"
>            
>            <Directory "C:/wwwroot/site-two.it/v2.0">
>                        Options FollowSymlinks Indexes Includes ExecCGI
>                        Order allow,deny
>                        Allow from all
>                        DirectoryIndex default.htm default.aspx
>            </Directory>

Go ahead and drop this out of the vhosts section.

></VirtualHost>
> 
> 
>I want site-one to be an ASP.NET application and site-two to be a separate
application. They are distinguished only by the host name the client uses to
access my server.
>Aside that the docs states that AspNetMount can be placed only OUTSIDE a
VirtualHost directive (but in this way apache always give me error when
doing a request)

... it shouldn't!  what error?

>, this configuration seem to work. If I access site-one it’s working
perfectly. 
>If I access site-two it’s warking also (aspx pages are served correctly)
BUT it doesn’t handle session correctly.
>The same site under IIS is working correctly…
>It seems to me that it’s a problem with the AspNetMount directive but I
tried different combinations and I just cant get it…

Try reversing the two apps and hosts.  Position/order issues 
often just pop out at you, and we can narrow down the problem.



---------------------------------------------------------------------
To unsubscribe, e-mail: cli-users-unsubscribe@httpd.apache.org
For additional commands, e-mail: cli-users-help@httpd.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: cli-users-unsubscribe@httpd.apache.org
For additional commands, e-mail: cli-users-help@httpd.apache.org


Mime
View raw message