httpd-cli-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos C <ccana...@satx.rr.com>
Subject Re: [cli-users] Problem using ASP.NET
Date Sun, 29 May 2005 15:45:08 GMT
right beside the modules sections is where i have it. a safe way to do 
it is the following:
---------------
LoadModule aspdotnet_module modules/mod_aspdotnet.so
AddHandler asp.net asax ascx ashx asmx aspx axd config cs csproj \
                    licx rem resources resx soap vb vbproj vsdisco webinfo
AspNetVersion v1.1.4322
-----------------
and then
you put the extra stuff inside an <IfModule>
------------------
<IfModule mod_aspdotnet.cpp>
AliasMatch "^/(?i)aspnet_client/system_web/(\d+)_(\d+)_(\d+)_(\d+)/(.*)" 
\ 
"C:/Windows/Microsoft.NET/Framework/v$1.$2.$3/ASP.NETClientFiles/$4"

<Directory "C:/Windows/Microsoft.NET/Framework/v*/ASP.NETClientFiles">
         Options FollowSymlinks
         Order allow,deny
         Allow from all
</Directory>
</IfModule>
------------------
you don't need any extra includes in your aspx or anything. the only 
thing is that you have to declare a directory per asp.net application 
(inside your <IfModule>).
for example, inside your IfModule, add a directory for your example:
------------------
AspNetMount /app "C:\example" #the uri would be http://httpd/app/
<Directory "C:\example>
         Options FollowSymlinks Indexes Includes ExecCGI
         Order allow,deny
         Allow from all
         DirectoryIndex default.aspx  #called on index.
</Directory>
------------------
your code would be in default.aspx inside c:\example.

Sam Pike wrote:
> Hello,
> 
> I am trying to configure Apache so I can test ASP.NET files locally.
> Although I have to say I am finding it quite difficult and would
> greatly appreciate some help.
> 
> I have installed Apache and have the .NET framework. I have also
> installed the ASP.NET module found at the following location
> 
> http://httpd.apache.org/cli/
> 
> and tried to configure this in the httpd.conf file following the
> instructions listed here
> 
> http://httpd.apache.org/cli/mod_aspdotnet
> 
> However, I am not sure where to put the code found in the above page
> in the .conf file, and what to include in my .aspx file. Could you
> help me to get the following ASP.NET code working please, it's from
> w3schools. I have saved it in htdocs but when I try to load it I just
> see the code.
> 
> Thanks for any help
> 
> <script  runat="server">
> Sub Page_Load
> if Not Page.IsPostBack then
>   lbl1.Text="The date and time is " & now()
> end if
> End Sub
> 
> Sub submit(s As Object, e As EventArgs)
> lbl2.Text="Hello World!"
> End Sub
> </script>
> 
> <html>
> <body>
> <form runat="server">
> <h3><asp:label id="lbl1" runat="server" /></h3>
> <h3><asp:label id="lbl2" runat="server" /></h3>
> <asp:button text="Submit" onclick="submit" runat="server" />
> </form>
> </body>
> </html>
> 
> Does php also require the inclusion of other modules?
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cli-users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: cli-users-help@httpd.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: cli-users-unsubscribe@httpd.apache.org
For additional commands, e-mail: cli-users-help@httpd.apache.org


Mime
View raw message