httpd-cli-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Francois Cantin <jfsu...@telus.net>
Subject Re: [cli-users] CruiseControl.Net configuration error
Date Fri, 25 Feb 2005 04:16:59 GMT
Thanks Bill,

Is there anything I can do to try to fix this in the meantime or 
anything I can do to narrow it down?

Jean-Francois

William A. Rowe, Jr. wrote:

>There is a known (but unidentified) double-loading error, right
>now, in the server.  Starting Apache.exe with the -x flag (for
>no parent process) does not solve it.  Vetting the code, we only
>-seem- to instantiate the host once.
>
>The more eyes on this, the better.  Would like to see this fixed
>when we roll out the next version.
>
>Bill
>
>At 12:24 AM 2/23/2005, Jean-Francois Cantin wrote:
>  
>
>>Hi All,
>>
>>I installed CruiseControl.Net on my server(Win2kPro, Apache 2.0.52 standard install
with xampp) and serving the ccnet(cruise control.net) pages works fine with IIS and also works
when I try through Cassini by proxy using Apache..
>>
>>When I try using the mod_aspdotnet to serve the ccnet page I get an error saying that
I have an error in my config file. The config file is unmodified from the original ccnet install.
>>
>>The only thing I can think of is that the <sectionGroup name="sitemesh"> is
conflicting with the name "SiteMesh" from the error? is there anything different between the
Apache parser and IIS?
>>
>>Has anyone been successful at installing ccnet and running it with Apache?
>>
>>Thanks for your help.
>>
>>Jean-Francois Cantin
>>
>>P.S. I am running asp.net 1.1
>>below are the error message, the top of the web.config file and a section of my http.conf
>>
>>-----------------------------------
>>Server Error in '/ccnet' Application.
>>Configuration Error
>>Description: An error occurred during the processing of a configuration file required
to service this request. Please review the specific error details below and modify your configuration
file appropriately.
>>
>>Parser Error Message: The module 'SiteMesh' is already in the application and cannot
be added again
>>
>>Source Error:
>>
>>Line 23:     <system.web>
>>Line 24:         <httpModules>
>>Line 25:             <add type="SiteMesh.Filter.SiteMeshModule, SiteMesh" name="SiteMesh"
/>
>>Line 26:         </httpModules>
>>Line 27:         <!--  DYNAMIC DEBUG COMPILATION
>>
>>
>>Source File: D:\devtools\ccnet\web\web.config    Line: 25
>>
>>Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET Version:1.1.4322.2032
>>---------------------------------------------
>>
>>
>>Web.config file-------------------------------
>><?xml version="1.0" encoding="utf-8" ?>
>><configuration>
>>  <configSections>
>>      <sectionGroup name="sitemesh">
>>          <section name="page-parsers" type="SiteMesh.Factory.PageParsersSectionHandler,
SiteMesh" />
>>          <section name="decorator-mappers" type="SiteMesh.Factory.DecoratorMappersSectionHandler,
SiteMesh" />
>>          <section name="decorators" type="SiteMesh.Mapper.DecoratorSectionHandler,
SiteMesh" />
>>      </sectionGroup>
>>      <sectionGroup name="CCNet">
>>          <section name="xslFiles" type="ThoughtWorks.CruiseControl.Core.Config.XslFilesSectionHandler,ThoughtWorks.CruiseControl.Core"
/>
>>          <section name="projectPlugins" type="ThoughtWorks.CruiseControl.Web.PluginsSectionHandler,ThoughtWorks.CruiseControl.Web"
/>
>>          <section name="buildPlugins" type="ThoughtWorks.CruiseControl.Web.PluginsSectionHandler,ThoughtWorks.CruiseControl.Web"
/>
>>      </sectionGroup>
>>  </configSections>
>>  <appSettings>
>>      <!-- CHANGE THIS to be the absolute path of the directory used by the XmlLogPublisher
of
>>          your project configuration in the build server. For more information, see
the
>>          'Project Report Web Application' page in the Documentation -->
>>      <add key="logDir" value="log" />
>>      <add key="ServerLogFilePath" value="c:\program files\CruiseControl\server\ccnet.log"
/>
>>      <add key="ServerLogFileLines" value="50" />
>>  </appSettings>
>>  <system.web>
>>      <httpModules>
>>          <add type="SiteMesh.Filter.SiteMeshModule, SiteMesh" name="SiteMesh"
/>
>>      </httpModules>
>>...
>>------------------------------------------
>>
>>Here is my apache conf. I checked my directory tree and all directories are lower
cases:
>>
>>######  ASP.NET using mod_aspdotne t###################
>>LoadModule aspdotnet_module modules/mod_aspdotnet.so
>>
>># Use the asp.net handler for all common ASP.NET file types
>>AddHandler asp.net asax ascx ashx asmx aspx axd config cs csproj \
>>                 licx rem resources resx soap vb vbproj vsdisco webinfo
>>
>><IfModule mod_aspdotnet.cpp>
>>
>>########### CCNET Setup ############
>>  # Mount the CCNET application
>>  AspNetMount /ccnet "D:\devtools\ccnet\web"
>>
>>  # Map all requests for /ccnet to the ccnet application files
>>  Alias /ccnet "D:\devtools\ccnet\web"
>>
>>  # Allow asp.net scripts to be executed
>>  <Directory "D:\devtools\ccnet\web">
>>      Options FollowSymlinks ExecCGI
>>      Order allow,deny
>>      Allow from all
>>      DirectoryIndex Default.htm Default.aspx
>>  </Directory>
>>########## CCNET Setup END ############### 
>>  # For all virtual ASP.NET webs, we need the aspnet_client files
>>  # to serve the client-side helper scripts.
>>  AliasMatch /aspnet_client/system_web/(\d+)_(\d+)_(\d+)_(\d+)/(.*) \
>>        
>>"C:/Windows/Microsoft.NET/Framework/v1.1.4322/ASP.NETClientFiles/$4"
>>  <Directory \
>>        "C:/Windows/Microsoft.NET/Framework/v1.1.4322/ASP.NETClientFiles">
>>      Options FollowSymlinks
>>      Order allow,deny
>>      Allow from all
>>  </Directory>
>>
>></IfModule>
>>
>>####### ASP.NET END ##############################3
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: cli-users-unsubscribe@httpd.apache.org
>>For additional commands, e-mail: cli-users-help@httpd.apache.org
>>
>>    
>>
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: cli-users-unsubscribe@httpd.apache.org
>For additional commands, e-mail: cli-users-help@httpd.apache.org
>
>
>  
>


Mime
View raw message