httpd-cli-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Morrison <mmorris...@yahoo.com>
Subject [cli-users] 500 Internal Error
Date Thu, 03 Feb 2005 02:00:17 GMT
Hello! I'm quite excited about the prospect of ASP.NET on Apache, but
I'm encountering a problem. Whenever I try to browse to a simple .aspx
file Apache returns a 500 Internal Server Error. This is a fresh
install (using the .msi) of Apache 2.0.52 on WinXP Pro with
mod_aspdotnet the only not-out-of-the-box module. I am unsure of
whether this is a configuration problem or a bug. Could anyone shed
some light on this?

Log entry:
[Wed Feb 02 19:14:38 2005] [error] [client 127.0.0.1] mod_aspdotnet:
Failed to create ASP.NET Request, Exception follows, referer:
http://localhost/sa/
[Wed Feb 02 19:14:38 2005] [error] mod_aspdotnet: HandleRequest: Failed
with unexpected Exception; System.TypeLoadException: Could not load
type 'Apache.Native.apr_table_t' from assembly 'Apache.Web,
Version=2.0.0.2000, Culture=neutral,
PublicKeyToken=9b9b842f49b86351'.\r\n   at
Apache.Web.Host.HandleRequest(Int32 Req)\r\n   at
Apache.Web.HostFactory.HandleHostRequest(Int32 HostKey, Int32 Req)

The only modification I've made to httpd.conf is the addition of:

LoadModule aspdotnet_module modules/mod_aspdotnet.so

AddHandler asp.net asax ascx ashx asmx aspx axd config cs csproj \
                   licx rem resources resx soap vb vbproj vsdisco
webinfo

<IfModule mod_aspdotnet.cpp>

  # Mount the SA application
  AspNetMount /sa "F:/projects/sandbox/SA/result"
  
  # Map all requests for SA files to the SA application files
  Alias /sa "F:/projects/sandbox/SA/result"
  
  # Allow ASP.NET scripts to be executed in the SA application
  <Directory "F:/projects/sandbox/SA/result">
      Options FollowSymlinks Indexes Includes ExecCGI
      Order allow,deny
      Allow from all
      DirectoryIndex default.htm default.aspx
  </Directory>
  
  # For all virtual ASP.NET webs, we need the aspnet_client files 
  # to serve the client-side helper scripts.
  AliasMatch
"^/(?i)aspnet_client/system_web/(\d+)_(\d+)_(\d+)_(\d+)/(.*)" \
            
"C:/Windows/Microsoft.NET/Framework/v$1.$2.$3/ASP.NETClientFiles/$4"
  <Directory \
        "C:/Windows/Microsoft.NET/Framework/v*/ASP.NETClientFiles">
      Options FollowSymlinks
      Order allow,deny
      Allow from all
  </Directory>

</IfModule>

I have .NET framework versions 1.0.3705, 1.1.4322, and 2.0.40607
installed. Apache.Web.dll shows up in the GA (C:/Windows/assemblies)
although I can't find it on the disk.

Does anyone have suggestions about what I might do about this, or at
least where to look further? I can provide further information if
needed.

Thanks,
  Matt Morrison



		
__________________________________ 
Do you Yahoo!? 
Read only the mail you want - Yahoo! Mail SpamGuard. 
http://promotions.yahoo.com/new_mail 

---------------------------------------------------------------------
To unsubscribe, e-mail: cli-users-unsubscribe@httpd.apache.org
For additional commands, e-mail: cli-users-help@httpd.apache.org


Mime
View raw message