httpd-cli-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39007] New: - mod_aspdotnet can't find WebResource.axd
Date Fri, 17 Mar 2006 06:01:14 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39007>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39007

           Summary: mod_aspdotnet can't find WebResource.axd
           Product: Apache mod_aspdotnet
           Version: 2.0.0
          Platform: PC
        OS/Version: All
            Status: NEW
          Keywords: FAQ
          Severity: minor
          Priority: P2
         Component: mod_aspdotnet
        AssignedTo: cli-dev@httpd.apache.org
        ReportedBy: dovid@hotmail.com


When using server (ASPDOTNET 2.0) genrated controls (TreeView in particular),
Apache can't find WebResource.axd which is a phantom file used in the callback
functionailty of the 2.0 platform. Server generated graphics and javascript does
not work properly in the resulting pages. (i.e. the little node icons don't
appear and the JavaScript Debugger in IE reports all kinds of Script errors)

I did find a fix, that was to create an empty file in the Application Directory
and call it WebResource.axd as the DotNet Platform doesn't really read the file
at all. After that, DotNet 2.0 ran perfectly with Apache 2.0.55 And
Mod_AspDotNet 2.0.

Example:
Supposing in my httpd.conf I have the following lines to map a folder as an ASP App:
## Begin HTTPD.CONF
AspNetMount /app "C:/HTML/app"
Alias /app "C:/HTML/app"
## END HTTPD.CONF
I then make a new file in the folder "C:\HTML\app" and call it "WebResource.axd".

I hope this isn't a waste of your time as I was googling for hours and could not
 find a fix for this problem.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

Mime
View raw message