httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 61613] Facing issue to start Apache after upgrading to 2.4.28 -libssl.so.1.1: cannot open shared object file: No such file or directory
Date Fri, 13 Oct 2017 14:47:13 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=61613

--- Comment #4 from dferradal@gmail.com ---

> 
> No I haven't set LD_LIBRARY_PATH separately as it was not required in prior
> versions(httpd 2.4.27 and prior).

You are making incorrect assumptions, as if this was a new httpd thing, when
what you describe is Linux/Unix operative system thing since, for ever.

It is *not* necessary *if* you compile against the operative system libssl
because those lib files are already in a path your binaries can find, but when
you compiled against libssl from another source, your operative system, not
just httpd need those SSL libs loaded somewhere if you want binaries to find
them.

Being that method:
/etc/ld.so.conf.d/

or LD_LIBRARY_PATHS called from envvars file before you run httpd.

> --with-ssl=/opt/SP/apache/dependency/openssl --enable-ssl 

According to this, you need at the very least
/opt/SP/apache/dependency/openssl/lib in LD_LIBRARY_PATH for mod_ssl to find
the ssl libs it was compiled against.

And yes, mod_ssl have always needed to find ssl libs it was compiled against,
unless compiled statically.

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message