httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 61610] New: Config test fails if loadfactor > 1 in version 2.4.28
Date Thu, 12 Oct 2017 13:29:44 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=61610

            Bug ID: 61610
           Summary: Config test fails if loadfactor > 1 in version 2.4.28
           Product: Apache httpd-2
           Version: 2.4-HEAD
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_proxy
          Assignee: bugs@httpd.apache.org
          Reporter: tkjoeglu@gmail.com
  Target Milestone: ---

When running config test; apachectl -t we get an error if the loadfactor is
larger than 1.

Our configuration works fine in 2.4.27, but fails in 2.4.28. 

Error received:
> apache2 - AH00526: Syntax error on line 8 of config/workers.conf: BalancerMember LoadFactor
must be a number between 1..100

Line 8 of config file in question:
> BalancerMember URL:12000 route=admin loadfactor=100 status=-N

If we change the loadcator to be between 0.0 and 1.0 it works in 2.4.28.

We have found another reference to the same problem:
https://translate.google.com/translate?sl=auto&tl=en&js=y&prev=_t&hl=en&ie=UTF-8&u=http%3A%2F%2Fd.hatena.ne.jp%2Frougeref%2F&edit-text=&act=url

Here's the merge with the change:
https://github.com/apache/httpd/commit/52ae772654a0ab213bedad2e1bd38bebb80b245c

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message