httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 60577] Mod cache not working, with apache set as forward http proxy
Date Mon, 20 Feb 2017 21:26:32 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=60577

Yann Ylavic <ylavic.dev@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #34616|0                           |1
        is obsolete|                            |

--- Comment #5 from Yann Ylavic <ylavic.dev@gmail.com> ---
Created attachment 34770
  --> https://bz.apache.org/bugzilla/attachment.cgi?id=34770&action=edit
Early vs final URIs used by mod_cache

Depending on whether mod_cache runs in forward proxy and quick handler modes,
or normal handler mode, its base path and query string
references/canonicalizations are not computed at the same time (before or after
quick_handler and proxy_detect transforms) and thus may differ.

This patch defines the cache_use_early_url() helper and use it wherever
appropriate for mod_cache to consistently refer to the same entity while
serving and/or caching the response, in both early and late cases.

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message