httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 59840] New: Segmentation fault during the request processing
Date Mon, 11 Jul 2016 02:18:36 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=59840

            Bug ID: 59840
           Summary: Segmentation fault during the request processing
           Product: Apache httpd-2
           Version: 2.4.23
          Hardware: Sun
                OS: Solaris
            Status: NEW
          Severity: major
          Priority: P2
         Component: mod_http2
          Assignee: bugs@httpd.apache.org
          Reporter: k.j.chernov@gmail.com

SunOS 5.10 Generic_150401-20 i86pc

Hi.

After turning on mod_http2 and enabling h2 protocol, I've noticed child crashes
approx. once per day:

[2016-07-08 21:07:10.035281] [core:notice] [pid 15804:tid 1] AH00051: child pid
1617 exit signal Segmentation fault (11), possible coredump in
/pub/apache/cores
[2016-07-09 18:13:12.624654] [core:notice] [pid 15804:tid 1] AH00051: child pid
675 exit signal Segmentation fault (11), possible coredump in /pub/apache/cores

Got two core dumps for now:
$ mdb core.apache.httpd.1617.1467990419 
Loading modules: [ ld.so.1 libc.so.1 libuutil.so.1 ]
> ::stack
libcrypto.so.1.0.0`X509_get_ext_d2i()
mod_ssl.so`modssl_var_extract_san_entries+0x56()
mod_ssl.so`ssl_hook_Fixup+0x1b9()
ap_run_fixups+0x61()
ap_process_request_internal+0xd08()
ap_process_async_request+0x6f7()
ap_process_request+0x24()
mod_http2.so`h2_task_process_request+0x3fd()
mod_http2.so`h2_task_process_conn+0x228()
ap_run_process_connection+0x61()
mod_http2.so`h2_task_do+0x5e2()
mod_http2.so`execute+0x50()
libapr-1.so.0.5.2`dummy_worker+0x30()
libc.so.1`_thr_setup+0x5b()
libc.so.1`_lwp_start()

$ mdb core.apache.httpd.675.1468066381 
Loading modules: [ ld.so.1 libc.so.1 libuutil.so.1 ]
> ::stack
libcrypto.so.1.0.0`X509_get_subject_name()
mod_ssl.so`ssl_hook_Fixup+0x19f()
ap_run_fixups+0x61()
ap_process_request_internal+0xd08()
ap_process_async_request+0x6f7()
ap_process_request+0x24()
mod_http2.so`h2_task_process_request+0x3fd()
mod_http2.so`h2_task_process_conn+0x228()
ap_run_process_connection+0x61()
mod_http2.so`h2_task_do+0x5e2()
mod_http2.so`execute+0x50()
libapr-1.so.0.5.2`dummy_worker+0x30()
libc.so.1`_thr_setup+0x5b()
libc.so.1`_lwp_start()
> 

Tested with both 2.4.18/2.4.23, openssl 1.0.2g/1.0.2h.

If there's anything more I can do -- will be glad to help.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message