httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 59709] <If> can't see reqenv variables from some modules.
Date Wed, 15 Jun 2016 16:00:52 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=59709

--- Comment #3 from Eric Covener <covener@gmail.com> ---
(In reply to Andrey Chernov from comment #2)
> (In reply to Eric Covener from comment #1)
> > I don't think what you suggest is wise, as it would delay the correct
> > per-directory configuration being available to anything enclosed in <If>.
> > 
> > mod_geoip2 seems to run quite early when the config is server-wide, just
> > like mod_setenvif. Have you tried mod_geoip2 w/o delaying the execution by
> > putting it in per-directory config?
> 
> I have many virtual hosts and many directories, so run mod_geoip2
> server-wide once for all of them. I don't think that opening mod_geoip2
> database in per-(many)directory scope each time will speed things up.

I meant the opposite, but you already have the config that should set variables
early.  It's surprising that the variables are not available if you use it in
server scope already, but I didn't look at geoip2 in detail.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message