httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 59565] Apache 2.4.20 AddDefaultCharset doesn't work
Date Fri, 17 Jun 2016 21:56:07 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=59565

--- Comment #2 from joeborge@yahoo.com ---
Here is the header from one of the virtual hosts (chung-shan.hsiao.net):

HTTP/1.1 200 OK => 
Date => Fri, 17 Jun 2016 21:50:57 GMT
Server => Apache/2.4.20 (Unix) OpenSSL/1.0.1m SVN/1.9.4 PHP/5.6.20
Last-Modified => Sat, 31 Oct 2015 17:58:37 GMT
ETag => "a66-5236a4b19aa98"
Accept-Ranges => bytes
Content-Length => 2662
Cache-Control => max-age=0
Expires => Fri, 17 Jun 2016 21:50:57 GMT
Connection => close
Content-Type => text/html; charset=big5

I used "http://www.webconfs.com/http-header-check.php" to check the http
header.
This is when the virtual server has the following settings:

    AddDefaultCharset big5
    ForceType text/html

When I comment out "ForceType text/html", the header becomes:


HTTP/1.1 200 OK => 
Date => Fri, 17 Jun 2016 21:54:09 GMT
Server => Apache/2.4.20 (Unix) OpenSSL/1.0.1m SVN/1.9.4 PHP/5.6.20
X-Powered-By => PHP/5.6.20
Cache-Control => max-age=0
Expires => Fri, 17 Jun 2016 21:54:09 GMT
Content-Length => 2662
Connection => close
Content-Type => text/html; charset=UTF-8

charset becomes UTF-8 even with "AddDefaultCharset big5" set.

Apache 2.2.x didn't seem to have this issue.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message