httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 59313] New: module mod_http2 - incorrect protocol version string.
Date Tue, 12 Apr 2016 17:56:27 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=59313

            Bug ID: 59313
           Summary: module mod_http2 - incorrect protocol version string.
           Product: Apache httpd-2
           Version: 2.4.18
          Hardware: All
                OS: All
            Status: NEW
          Severity: trivial
          Priority: P2
         Component: mod_http2
          Assignee: bugs@httpd.apache.org
          Reporter: software+httpd@kd6lvw.ampr.org

RFC 3875 defines the HTTP version number as "<major>.<minor>" for the purposes
of the CGI variable "SERVER_PROTOCOL".  This implementation simply has
"HTTP/2", which has no minor number.

Change line 408 of file modules/http2/h2_request.c to read "HTTP/2.0".

     ap_parse_uri(r, req->path);
-    r->protocol = (char*)"HTTP/2";
+    r->protocol = (char*)"HTTP/2.0";
     r->proto_num = HTTP_VERSION(2, 0);

RFC 7540 did NOT override RFC 3875 but claims backward compatibility.  Granted
that RFC 7540 refers to the second, binary implementation of HTTP as "HTTP/2",
that was insufficient to override the ABNF syntax for the CGI interface in the
absence of an affirmation of such an override.

RFC 3875, Section 4.1.16 ABNF:

    HTTP-Version      = "HTTP" "/" 1*digit "." 1*digit

The "minor" number is not optional.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message