httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 58854] RewriteRule in .htaccess ignores 'Require all denied' when 403 ErrorDocument is missing
Date Mon, 29 Feb 2016 14:55:46 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=58854

--- Comment #12 from Jacob P <jacob.perkins@cpanel.net> ---
(In reply to Eric Covener from comment #9)
> (In reply to Jacob P from comment #8)
> > We've noticed a spike in tickets about RewriteRules no longer working after
> > this patch. Granted, these rewrite rules look conspicuous, as in, they
> > shouldn't work, or will result in looping, however we have enough reports of
> > them that we think this might be a regression in behavior. We've verified
> > these rewrites work before this patch, and now results in a ISE 500 /
> > Max10Redirects after the patch.
> 
> Sorry and thanks for the report. I think I now see what went wrong in the
> patch -- all different permutations of URLs, paths, and converted paths are
> handled in this block.
> 
> Here is a followup that restores the original check and uses a slightly
> different check at the last moment:
> 
> http://people.apache.org/~covener/patches/trunk-rewrite-deadloop2.diff
> 
> I am hoping you can try some of those failing ones.


Our initial testing advises that the fix for rewrites looping works, but the
original issue persists, that the RewriteRule ignores any Requires.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message