httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 58456] New: Compilation http 2.4.16 on MacOS 10.11 failed with "OpenSSL version is too old"
Date Thu, 24 Sep 2015 15:09:30 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=58456

            Bug ID: 58456
           Summary: Compilation http 2.4.16 on MacOS 10.11 failed with
                    "OpenSSL version is too old"
           Product: Apache httpd-2
           Version: 2.0-HEAD
          Hardware: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Build
          Assignee: bugs@httpd.apache.org
          Reporter: mpepito13@yahoo.fr

hello,

there is an error while compiling mod_ssl within http 2.4.16 on El Capitan
10.11.1.
This is strange because it works on 10.9 and 10.10. OpenSSL doesn't seems to
have been modified between these versions.

It is looking for OpenSSL version >= 0.9.8a:
    checking for OpenSSL... checking for user-provided OpenSSL base
directory... none  
    checking for OpenSSL version >= 0.9.8a... FAILED  
    configure: WARNING: OpenSSL version is too old  

The default OpenSSL version is 0.9.8zg (this is the same on 10.9 and 10.10):
    $ openssl version  
    OpenSSL 0.9.8zg 14 July 2015  

And finally here is a part of my compilation line:
    ./configure --prefix=/tmp/httpd-2.4.16 \
    --with-pcre=/tmp/pcre-8.37 \
    --with-included-apr  --with-socache_shmcb \
    --enable-setenvif --enable-ssl \
    --disable-access-compat --disable-actions --disable-alias
--disable-allowmethods --disable-auth-basic --disable-auth-digest
--disable-auth-form --disable-authn_anon --disable-authn-core
--disable-authn-dbd --disable-authn-dbm --disable-authn-file
--disable-authn-socache --disable-authz-host --disable-authnz-ldap
--disable-authz-dbd --disable-authz-dbm --disable-authz-groupfile
--disable-authz-owner --disable-authz-user --disable-autoindex --disable-buffer
--disable-cache-disk --disable-cache --disable-cgid --disable-dav-fs
--disable-dav --disable-dbd --disable-deflate --disable-dumpio --disable-env
--disable-expires --disable-ext-filter --disable-file-cache --disable-filter
--disable-headers --disable-include --disable-info
--disable-lbmethod-bybusyness --disable-lbmethod-byrequests
--disable-lbmethod-bytraffic --disable-lbmethod-heartbeat --disable-ldap
--disable-log-debug --disable-logio --disable-macro --disable-negotiation
--disable-proxy-ajp --disable-proxy-balancer --disable-proxy-connect
--disable-proxy-express --disable-proxy-fcgi --disable-proxy-ftp
--disable-proxy-http --disable-proxy-scgi --disable-proxy --disable-ratelimit
--disable-remoteip --disable-reqtimeout --disable-request --disable-rewrite
--disable-sed --disable-session-cookie --disable-session-dbd --disable-session
--disable-slotmem-shm --disable-socache-dbm --disable-socache-memcache
--disable-cache-socache --disable-speling --disable-status --disable-substitute
--disable-unique-id --disable-userdir --disable-version --disable-vhost-alias 

And the compilation variables :
    MACOSX_MIN_VERSION=10.7
    ARCH_64="-arch x86_64"
    ARCH="$ARCH_64 -mmacosx-version-min=$MACOSX_MIN_VERSION"
    CXXFLAGS="-O3 -fno-common $ARCH"
    CFLAGS="-O3 -fno-common $ARCH"
    LDFLAGS="-O3 $ARCH"
    CC="gcc $ARCH"
    CXX="g++ $ARCH"
    CPP="gcc -E"
    CXXCPP="g++ -E"


I tried to bypass the version verification as seen on the user list (by
removing the openssl version checking starting at line 24787) but it didn't
worked.
I then tried to fix the variable ac_cv_openssl=yes at line 24800. The configure
worked but then an error occured during the make : Cannot find openssl/rsa.h


Regards,
arnaud

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message