httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 58437] mod_h2: h2c doesn't work using upgrade from http 1.1
Date Tue, 22 Sep 2015 14:57:33 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=58437

--- Comment #16 from Javier Gusano Martinez <javier.gusano@hpe.com> ---
(In reply to Stefan Eissing from comment #15)
> What I use is something like:
> 
> ./configure --prefix=/opt/apache-trunk --enable-mpms-shared=all
> --with-included-apr --with-crypto --enable-ssl --enable-maintainer-mode
> --with-ssl=/opt/apache-trunk --enable-h2 --with-nghttp2=/opt/apache-trunk/
> 
> which for you might translate to
> 
> ./configure --prefix=/opt/apache-trunk  --enable-mpms-shared=all
> --with-crypto --enable-ssl --with-ssl=/usr --enable-h2
> --with-nghttp2=/home/sysadmin/Apache_mod_h2/downloads/nghttp2-1.3.2/lib/.
> libs/libnghttp2.so.14
> 
> Of course, you might not need the enable-moms-shared=all if you know what
> you want.

I think that I have followed your instructions but It doesn't works for me... I
have published on the installation repository
(https://github.com/jgm1986/Apache_mod_h2) the steps for the installation
(inside apache.sh script file).

On the other hand, I have published the following two Apache config files:
- httpd.conf
- httpd-vhosts.conf

This is the cURL output:

$ curl --http2 -v https://127.0.0.1:443
* Rebuilt URL to: https://127.0.0.1:443/
*   Trying 127.0.0.1...
* Connected to 127.0.0.1 (127.0.0.1) port 443 (#0)
* Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* TLSv1.2 (IN), TLS handshake, Server hello (2):
* TLSv1.2 (IN), TLS handshake, Certificate (11):
* TLSv1.2 (IN), TLS handshake, Server key exchange (12):
* TLSv1.2 (IN), TLS handshake, Server finished (14):
* TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
* TLSv1.2 (OUT), TLS change cipher, Client hello (1):
* TLSv1.2 (OUT), TLS handshake, Finished (20):
* TLSv1.2 (IN), TLS change cipher, Client hello (1):
* TLSv1.2 (IN), TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES128-GCM-SHA256
* Server certificate:
*        subject: C=ES; ST=Madrid; L=Madrid; O=Telefonica Investigacion y
Desarrollo; CN=*.bluevia.com
*        start date: 2014-10-06 00:00:00 GMT
*        expire date: 2016-01-05 23:59:59 GMT
* SSL: certificate subject name '*.bluevia.com' does not match target host name
'127.0.0.1'
* Closing connection 0
* TLSv1.2 (OUT), TLS alert, Client hello (1):

As you can see, ALPN is not present... -_-' Thanks for your help!

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message