httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 58197] New: apr-util-1.5.4 build against openldap - "could not find an LDAP library"
Date Fri, 31 Jul 2015 08:31:00 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=58197

            Bug ID: 58197
           Summary: apr-util-1.5.4 build against openldap - "could not
                    find an LDAP library"
           Product: Apache httpd-2
           Version: 2.5-HEAD
          Hardware: Other
                OS: AIX
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Build
          Assignee: bugs@httpd.apache.org
          Reporter: christian.tremel@itsv.at

AIX Version: 6100-08-01-1245
XLC Version: 13.1.0.3 

openldap-2.4.41 compiled from source.

/tmp/apachetest/dev/lib # ls -ltr | grep ldap
-rw-r--r--    1 root     system          888 Jul 31 09:44 libldap_r.la
-rw-r--r--    1 root     system       944537 Jul 31 09:44 libldap_r.a
-rw-r--r--    1 root     system          882 Jul 31 09:44 libldap.la
-rw-r--r--    1 root     system       861977 Jul 31 09:44 libldap.a
-rwxr-xr-x    1 root     system      1031094 Jul 31 10:07 libldap_r.so
-rwxr-xr-x    1 root     system       938970 Jul 31 10:07 libldap.so

/tmp/apachetest/dev/include # ls -ltr | grep ldap
-rw-r--r--    1 root     system         3468 Jul 31 09:44 ldap_utf8.h
-rw-r--r--    1 root     system         9450 Jul 31 09:44 ldap_schema.h
-rw-r--r--    1 root     system         1814 Jul 31 09:44 ldap_features.h
-rw-r--r--    1 root     system         9466 Jul 31 09:44 ldap_cdefs.h
-rw-r--r--    1 root     system        64783 Jul 31 09:44 ldap.h

my build script for apr-util:

#!/bin/ksh

#export LIBPATH="/tmp/apachetest/dev/lib:/usr/lib:/lib"
export PATH="/tmp/apachetest/dev/bin:$PATH"
export  OBJECT_MODE=64
export CC="cc_r"
export CFLAGS="-q64 -qsmp -qmaxmem=16384 -qenum=small -DNDEBUG -DSYSV -D_AIX
-D_AIX32 -D_AIX41 -D_AIX43 -D_AIX51 -D_AIX52 -D_AIX53 -D_AIX61 -D_AIX71
-D_ALL_SOURCE -DFUNCPROTO=15 -O2 -I/tmp/apachetest/dev/include
-I/opt/freeware/include"
export CXX="xlC_r"
export CXXFLAGS=$CFLAGS
export LDFLAGS="-L/tmp/apachetest/dev/lib -L/opt/freeware/lib64
-L/opt/freeware/lib \
-Wl,-bmaxdata:0x80000000 -Wl,-bh:4 -Wl,-b64 -Wl,-bexpall -Wl,-bnolibpath"


./configure \
     --prefix=/tmp/apachetest/apr \
     --exec-prefix=/tmp/apachetest/apr \
     --with-apr=/tmp/apachetest/apr \
     --with-crypto \
     --with-openssl=/tmp/apachetest/dev \
     --with-ldap=/tmp/apachetest/dev \
     --with-ldap-lib=/tmp/apachetest/dev/lib \
     --with-ldap-include=/tmp/apachetest/dev/include

produces

...

 adding "-I/tmp/apachetest/dev/include" to CPPFLAGS
configure: checking for openssl in /tmp/apachetest/dev
checking openssl/x509.h usability... yes
checking openssl/x509.h presence... yes
checking for openssl/x509.h... yes
checking for BN_init in -lcrypto... yes
checking for SSL_accept in -lssl... yes
  setting APRUTIL_LDFLAGS to "-L/tmp/apachetest/dev/lib"
  setting APRUTIL_INCLUDES to "-I/tmp/apachetest/dev/include"
checking whether EVP_PKEY_CTX_new is declared... yes
  setting LDADD_crypto_openssl to "-L/tmp/apachetest/dev/lib  -lssl -lcrypto"
checking for const input buffers in OpenSSL... yes
checking for ldap support...
checking for ldap_init in -l/tmp/apachetest/dev... no
checking for ldap_init in -l/tmp/apachetest/dev... no
checking for ldap_init in -l/tmp/apachetest/dev... no
checking for ldap_init in -l/tmp/apachetest/dev... no
configure: error: could not find an LDAP library

i am fighting with this since 2 days. what is the correct syntax for the ldap
stuff on the configure command?

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message