httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 57370] New: Encountering a problem when we try Configuring with coldfusion 8
Date Fri, 19 Dec 2014 10:02:46 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=57370

            Bug ID: 57370
           Summary: Encountering a problem when we try Configuring with
                    coldfusion 8
           Product: Apache httpd-2
           Version: 2.4.10
          Hardware: PC
                OS: SunOS
            Status: NEW
          Severity: normal
          Priority: P2
         Component: All
          Assignee: bugs@httpd.apache.org
          Reporter: kavya.t16@gmail.com

We tried this command for configuring with coldfusion 8--
/ColdFusion8/runtime/bin->./wsconfig -server coldfusion -ws Apache -dir
/etc/http/apache/conf -v

It ended up in this error.
httpd: Syntax error on line 491 of /etc/http/apache/conf/httpd.conf: Cannot
load /appl/ColdFusion8/runtime/lib/wsconfig/2/mod_jrun22.so into server:
ld.so.1: httpd: fatal: relocation error: file
/appl/ColdFusion8/runtime/lib/wsconfig/2/mod_jrun22.so: Error running
"/etc/http/apache/bin/apachectl restart": exit code was 1
Error restarting Apache server.  The web server must be restarted to complete
this operation.
The Apache connector was installed to /etc/http/apache/conf
symbol ap_log_error: referenced symbol not found

Then we tried to modify the mod_jrun22.c by replacing the "remote_addr" with
"client_addr" in wsconfig.jar  and tried to recompile with the below command:

apxs -ic -n jrun mod_jrun24.c jrun_maptable_impl.c jrun_property.c
jrun_session.c platform.c jrun_mutex.c jrun_proxy.c jrun_utils.c

We get these errors:
/etc/http/apache/build/libtool --silent --mode=compile gcc -std=gnu99
-prefer-pic   -DSOLARIS2=10 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT
-D_LARGEFILE64_SOURCE -g -O2 -I/etc/http/apache/include 
-I/etc/http/apache/include   -I/etc/http/apache/include   -c -o mod_jrun24.lo
mod_jrun24.c && touch mod_jrun24.slo
mod_jrun24.c:579: warning: initialization from incompatible pointer type
mod_jrun24.c: In function `pstrdup_lower':
mod_jrun24.c:703: warning: implicit declaration of function `tolower'
/usr/ccs/bin/as: Permission denied
/usr/ccs/bin/as: error: cannot open output file ".libs/mod_jrun24.o"
apxs:Error: Command failed with rc=65536

Please help!!!

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message