httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 56753] New: mod_lua.so: symbol luaL_openlib: referenced symbol not found
Date Mon, 21 Jul 2014 10:15:06 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=56753

            Bug ID: 56753
           Summary: mod_lua.so: symbol luaL_openlib: referenced symbol not
                    found
           Product: Apache httpd-2
           Version: 2.4.10
          Hardware: PC
                OS: Solaris
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_lua
          Assignee: bugs@httpd.apache.org
          Reporter: petr.sumbera@oracle.com

Created attachment 31837
  --> https://issues.apache.org/bugzilla/attachment.cgi?id=31837&action=edit
Possible fix.

When built with Lua 5.2.1:

httpd: Syntax error on line 129 of /etc/apache2/2.4/httpd.conf: Cannot load
libexec/mod_lua.so into server: ld.so.1: httpd: fatal: relocation error: file
/usr/apache2/2.4/libexec/mod_lua.so: symbol luaL_openlib: referenced symbol not
found

I have attached patch file which seems to fix the issue. The patch is based on
bellow info:

http://lua-users.org/wiki/CompatibilityWithLuaFive

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message