httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 56102] New: SSL_CLIENT_S_DN_x509_0 is undefined
Date Mon, 03 Feb 2014 12:06:54 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=56102

            Bug ID: 56102
           Summary: SSL_CLIENT_S_DN_x509_0 is undefined
           Product: Apache httpd-2
           Version: 2.4.6
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_ssl
          Assignee: bugs@httpd.apache.org
          Reporter: willy.weisz@univie.ac.at
                CC: willy.weisz@univie.ac.at

According to the description for mod_ssl multiple occurrences of x509
components are returned with a "_n" suffix, with n starting at 0. The
description also explicitly states that both forms ..._x509 and ..._x509_0
return the same value, the first ..._x509 attribute value.
My issue was that SSL_CLIENT_S_DN_OU returned the correct value, but
SSL_CLIENT_S_DN_OU_0 was undefined.
Providing ..._x509_0 provides allows to write compact code when scanning
through multiple same name attributes, whereas the present situation forces one
to single out the first component.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message