httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 55819] New: Closing connection behaviour
Date Wed, 27 Nov 2013 15:23:37 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=55819

            Bug ID: 55819
           Summary: Closing connection behaviour
           Product: Apache httpd-2
           Version: 2.2.3
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Core
          Assignee: bugs@httpd.apache.org
          Reporter: julien.rulliere@edokial.com

Hello.

I'm running Apache 2.2.3 as reverse proxy.
There are multiple virtual hosts running SSL.

I receive some requests with the "Connection: close" header set.
The connection is done under http version 1.0.
When my server is returning the response, the response is in http version 1.0,
with the header "Connection: close" set.

My client is claiming me that his application connecting my server is waiting
my server to close the connection. At the end, his application is very slow
because it spend a lot of time to wait my server to close the connection.
If a do network capture using wireshark, I can see that the server sends FIN
tcp flag after 10 or 15 seconds the response.

Is this a normal behaviour ?
How can I set up Apache to close the connection just after the response is
given ?

Thanks.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message