httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 43218] Wrong cert used for vhost if ServerName is same
Date Sat, 17 Aug 2013 01:38:06 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=43218

--- Comment #7 from Christoph Anton Mitterer <calestyo@scientia.net> ---
I've reported the same as bug #55047, and while this report here notes that it
happens on different ports (which just hit me now)... I only noted that it also
happens on the same port (i.e. multiple vhosts on the same IP:port, that just
differ in ServerAlias).

As shown at #557047, I'd have expected that Apache then simply takes the
"first" vhost when the ServerName is given as Host: header... and the
corresponding vhost when any ServerAlias is given as Host: header.


Of course you may say now that this is just cosmetic, and I could simply change
the ServerName of the second vhost (as it won't be ever matched anyway)... it's
a bit more... as ServerName is used as default in some places (canonical name
and such)... and e.g. people may want to use that to get things like redirects
back to the first (canonical) vhost.



Anyway... that issue is 6 years old now... is anything ever going to happen?

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message