httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 55194] New: debian wheezy and openssl 1.0: can't compile
Date Wed, 03 Jul 2013 19:16:40 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=55194

            Bug ID: 55194
           Summary: debian wheezy and openssl 1.0: can't compile
           Product: Apache httpd-2
           Version: 2.2-HEAD
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Build
          Assignee: bugs@httpd.apache.org
          Reporter: pippoppo@gmail.com

with regards to this commit:
http://svn.apache.org/viewvc?view=revision&revision=r1497466 
I can't compile on debian wheezy.

my configure:
./configure                        \
        --with-included-apr            \
                            \
        --enable-nonportable-atomics        \
                            \
        --enable-headers=shared            \
        --enable-expires=shared            \
        --enable-deflate=shared            \
        --enable-rewrite=shared            \
        --enable-cache=shared            \
        --enable-disk-cache=shared        \
        --enable-mem-cache=shared        \
        --enable-proxy=shared            \
        --enable-proxy_http=shared        \
        --enable-proxy_ftp=shared        \
        --enable-proxy-connect=shared        \
        --enable-proxy-ajp=shared        \
        --enable-ssl=shared            \
        --enable-unique_id=shared        \
        --enable-substitute=shared        \
        --enable-info                \
                            \
                            \
        --enable-authnz-ldap=shared        \
        --enable-ldap=shared            \
        --with-ldap                \
                            \
        --disable-userdir            \
                            \
        --with-mpm=event            \
                            \
        --enable-so                \


my ssl packages:
ii  libssl-dev                               1.0.1e-2                          
   amd64        SSL development libraries, header files and documentation
ii  libssl1.0.0:amd64                        1.0.1e-2                          
   amd64        SSL shared libraries



and this is the error I get:
ssl_engine_io.c: In function 'ssl_io_filter_connect':
ssl_engine_io.c:1082:36: error: 'SSL_PROTOCOL_SSLV2' undeclared (first use in
this function)
ssl_engine_io.c:1082:36: note: each undeclared identifier is reported only once
for each function it appears in


If I remove the following line, all works as usual:
diff -r httpd-2.2.25/modules/ssl/ssl_engine_io.c
/root/httpd-2.2.25/modules/ssl/ssl_engine_io.c
1081a1082
>             sc->proxy->protocol != SSL_PROTOCOL_SSLV2 &&



let me know if you need some more info

thanks

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message