httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 54548] New: <!--#elif expr=... --> always reports 'Invalid expression' error
Date Mon, 11 Feb 2013 14:55:29 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=54548

            Bug ID: 54548
           Summary: <!--#elif expr=... --> always reports 'Invalid
                    expression' error
           Product: Apache httpd-2
           Version: 2.4.3
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_include
          Assignee: bugs@httpd.apache.org
          Reporter: vvv+apache@colocall.net
    Classification: Unclassified

The following code doesn't work as expected:

<html>
<body>
<!--#set var="test_var" value="b"-->
<!--#if expr="v('test_var') == 'a'" -->
*if*
<!--#elif expr="v('test_var') == 'b'" -->
*elif*     
<!--#else -->
*else*     
<!--#endif -->
</body>    
</html>    

I've got

[an error occurred while processing this directive] *else*

and error message

Invalid expression "v('test_var') == 'b'"

in error.log instead of

*elif*

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message