httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 44302] AuthLDAPURL does not accept ldapi:// urls
Date Tue, 12 Feb 2013 19:11:33 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=44302

Stephane Chazelas <stephane.chazelas@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |stephane.chazelas@gmail.com
            Version|2.2.8                       |2.2.22

--- Comment #2 from Stephane Chazelas <stephane.chazelas@gmail.com> ---
Confirmed with apache 2.22 and apr-util 1.3.12 (from ubuntu 12.04). ldapi://
URLs don't work. Worse, if you enter ldapi:///, it is (silently) treated as
ldap://localhost:389, that is, the connection is still done over TCP to
localhost.

You can't use "EXTERNAL" type authentication (whereby the ldap server can
verify the user name that contacts it from the unix domain socket).

To verify, enter a ldapi://%2fvar%2frun%2fslapd%2dldapi/... URL and see the
wrong debug output as in Nikos' case, or enter ldapi:/// and see (with a
network capture or looking at netstat) that it's doing a TCP connection to port
389. You could also disable TCP in slapd to verify that it stops working.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message