httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 54252] New: acinclude.m4 requires -lz when linking with ssl static libraries
Date Wed, 05 Dec 2012 17:42:55 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=54252

            Bug ID: 54252
           Summary: acinclude.m4 requires -lz when linking with ssl static
                    libraries
           Product: Apache httpd-2
           Version: 2.4.3
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Runtime Config
          Assignee: bugs@httpd.apache.org
          Reporter: alanh@fairlite.co.uk
    Classification: Unclassified

openssl is  linked with -lz, so acinclude.m4 needs this modification for static
libraries.

Maybe this should be using pkg-config instead ?

--- acinclude.m4.old    2012-12-05 11:48:06.000000000 +0000
+++ acinclude.m4    2012-12-05 11:48:13.000000000 +0000
@@ -543,7 +543,7 @@
       [AC_MSG_RESULT(FAILED)])

     if test "x$ac_cv_openssl" = "xyes"; then
-      ap_openssl_libs="-lssl -lcrypto `$apr_config --libs`"
+      ap_openssl_libs="-lssl -lcrypto -lz `$apr_config --libs`"
       APR_ADDTO(SSL_LIBS, [$ap_openssl_libs])
       APR_ADDTO(LIBS, [$ap_openssl_libs])
       APACHE_SUBST(SSL_LIBS)

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message