httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [Bug 54140] New: Possible LDAP authentication regression with 2.2.23 release
Date Mon, 12 Nov 2012 18:11:43 GMT

          Priority: P2
            Bug ID: 54140
           Summary: Possible LDAP authentication regression with 2.2.23
          Severity: normal
    Classification: Unclassified
                OS: Mac OS X 10.4
          Hardware: PC
            Status: NEW
           Version: 2.2.23
         Component: mod_ldap
           Product: Apache httpd-2

I also added this as a comment in the closed bug: 39095.  I did not want to
simply reopen and old bug, but it looks similar.

I package Subversion Edge which bundles Apache 2.2.23 + SVN 1.7.7.  The version
that includes Apache 2.2.23 was only released on October 26th and we have
already had at least a dozen different users reporting they are now getting a
problem with LDAP authentication on Windows servers.

A user will get an HTTP 500 when making a Subversion request, and then
subsequent requests for that user will be fine again for a while.  When they
get the error, this is what is logged:

[info] [client] [1248] auth_ldap authenticate: user XXXXX
authentication failed; URI /svn/reposname [LDAP: ldap_simple_bind_s()

This is only happening with Windows Apache servers.  I note that the 2.2.23
release includes the following change, which seems innocuous but also seems to
be the only change related to LDAP in the CHANGES

--- httpd/httpd/branches/2.2.x/include/util_ldap.h      2012/08/21
17:48:34        1375695
+++ httpd/httpd/branches/2.2.x/include/util_ldap.h      2012/08/21
17:48:58        1375696
@@ -30,7 +30,7 @@
#include "apr_time.h"
#include "apr_ldap.h"
#define AP_LDAP_IS_SERVER_DOWN(s)                ((s) == LDAP_SERVER_DOWN
                 ||(s) == LDAP_UNAVAILABLE)

You are receiving this mail because:
You are the assignee for the bug.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message