httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 39095] ldap_simple_bind_s fails
Date Mon, 12 Nov 2012 18:07:49 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=39095

--- Comment #31 from Mark Phippard <markphip@gmail.com> ---
Is there any reason that the LDAP change committed to the 2.2.23 release would
have caused a regression and made this problem return?

I package Subversion Edge which bundles Apache 2.2.23 + SVN 1.7.7.  The version
that includes Apache 2.2.23 was only released on October 26th and we have
already had at least a dozen different users reporting they are now getting
this problem.

Users will get an HTTP 500 when making a Subversion request, and then
subsequent requests for that user will be fine again for a while.  When they
get the error, this is what is logged:

[info] [client 204.11.125.146] [1248] auth_ldap authenticate: user XXXXX
authentication failed; URI /svn/reposname [LDAP: ldap_simple_bind_s()
failed][Unavailable]

This is only happening with Windows Apache servers.  I note that the 2.2.23
release includes this change, which seems innocuous but also seems to be the
only change related to LDAP in the CHANGES

http://svn.apache.org/viewvc?view=revision&revision=1375696

--- httpd/httpd/branches/2.2.x/include/util_ldap.h      2012/08/21
17:48:34        1375695
+++ httpd/httpd/branches/2.2.x/include/util_ldap.h      2012/08/21
17:48:58        1375696
@@ -30,7 +30,7 @@
#include "apr_time.h"
#include "apr_ldap.h"
-#if APR_HAS_MICROSOFT_LDAPSDK
+#ifdef LDAP_UNAVAILABLE
#define AP_LDAP_IS_SERVER_DOWN(s)                ((s) == LDAP_SERVER_DOWN
\
                 ||(s) == LDAP_UNAVAILABLE)
#else

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message