httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 53140] "/server-status" & "/server-info" fail (File does not exist) to display
Date Tue, 24 Apr 2012 17:24:42 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=53140

locuse <locuse@mm.st> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEEDINFO                    |RESOLVED
         Resolution|                            |INVALID

--- Comment #2 from locuse <locuse@mm.st> 2012-04-24 17:24:42 UTC ---
the requested process of simplifying/flattening my *overall* config found the
problem -- just not where i was looking.

disabling modsecurity2 module fixed the problem -- /server-status &
/server-info both display as requested.

the (in?)direct cause, it seems, is that latest apr/apr-util seems seem to no
longer have an apu-*-config.  in config output for httpd, i note,

    ...
    configure: APR-util obsoleted, woohoo
    ...

in any case, modsecurity2 module build, which was previously 'happy' with
config option of just "--with-apxs=..." for httpd 2.4.x now *requires* (not
that it tells you that ...) an additional,

  --with-apr=/usr/local/apache24x/bin/apr-2-config
  --with-apu=/usr/local/apache24x/bin/apr-2-config

with those config options in place, a rebuild of modsecurity2, then reenabling
the module in apache24x, all's well again.

apologies for the more-or-less fire drill ...

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message