httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 53002] New: <Location> and auth_form (trailing slash problem?)
Date Thu, 29 Mar 2012 15:14:39 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=53002

             Bug #: 53002
           Summary: <Location> and auth_form (trailing slash problem?)
           Product: Apache httpd-2
           Version: 2.4.1
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Core
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: t.stein@syseleven.de
    Classification: Unclassified


Hello.

I have a virtual host configured with a location set to use auth_form:

        <Location /munin>
                #DirectorySlash Off
                AuthFormProvider file
                ErrorDocument 401 /login.shtml
                AuthUserFile /etc/apache2/.htpasswd 
                AuthType form
                AuthName Munin 
                #AuthFormLoginRequiredLocation http://xenbeere.de/login.html
                Session On
                SessionCookieName session path=/
                # SessionCryptoPassphrase secret
                Require valid-user

        </Location>

When i go to http://host/munin everything works fine. Auth form needs to filled
in and after that the page shows up.

But if i use hhtp://host/munin/ (note the trailing slash) the auth form shows
up and after entering the credentials "Internal Server Error" is shown. The log
says:

[Thu Mar 29 16:12:35.665238 2012] [core:error] [pid 5422:tid 140602179712768]
[client xxx.xxx.xxx.xxx:58670] AH00027: Buggy authn provider failed to set user
for /munin/index.html.var, referer: http://host/munin/

Even weirder. If i set this authenticator in .htaccess everything is working
fine.

Any hints? Do i something stupid again?

best regards
t.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message