httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 52802] Unable to Build Apache 2.4.1 on Solaris/X86 - Linker Problem
Date Sat, 03 Mar 2012 09:10:47 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=52802

Kaspar Brand <asfbugz@velox.ch> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |NEEDINFO

--- Comment #1 from Kaspar Brand <asfbugz@velox.ch> 2012-03-03 09:10:47 UTC ---
The relevant snippets are basically:

/opt/ae/build-1/libtool --silent --mode=link gcc -std=gnu99 -g -O2          -o
mod_ssl.la -rpath /opt/fd/apache2/modules -module -avoid-version  mod_ssl.lo
ssl_engine_config.lo ssl_engine_dh.lo ssl_engine_init.lo ssl_engine_io.lo
ssl_engine_kernel.lo ssl_engine_log.lo ssl_engine_mutex.lo
ssl_engine_pphrase.lo ssl_engine_rand.lo ssl_engine_vars.lo ssl_scache.lo
ssl_util_stapling.lo ssl_util.lo ssl_util_ssl.lo ssl_engine_ocsp.lo
ssl_util_ocsp.lo  -L/opt/ae/lib -lssl -lcrypto -luuid -lsendfile -lrt -lsocket
-lnsl -lpthread -export-symbols-regex ssl_module
Text relocation remains                     referenced
    against symbol            offset    in file
SSLv3_server_method_data.0          0x1          
/opt/ae/lib/libssl.a(s3_srvr.o)
SSLv3_server_method_data.0          0x11         
/opt/ae/lib/libssl.a(s3_srvr.o)
.rodata (section)                   0x177        
/opt/ae/lib/libssl.a(s3_srvr.o)
.rodata (section)                   0x5b3        
/opt/ae/lib/libssl.a(s3_srvr.o)
.rodata (section)                   0x5e9        
/opt/ae/lib/libssl.a(s3_srvr.o)
[...]
ld: fatal: relocations remain against allocatable but non-writable sections


I think that's the same issue which was mentioned quite some time ago here:

http://mail-archives.apache.org/mod_mbox/httpd-users/200511.mbox/%3C868b524f0511031831uc343f15iac0e8b3fcc159ba1@mail.gmail.com%3E

... i.e., not specific to 2.4 most likely - I assume you did not link 2.2.22
against that same OpenSSL version, or did you?

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message