httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 52794] Log file shows ssl port as 443
Date Wed, 07 Mar 2012 07:27:58 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=52794

Kaspar Brand <asfbugz@velox.ch> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |WONTFIX

--- Comment #4 from Kaspar Brand <asfbugz@velox.ch> 2012-03-07 07:27:58 UTC ---
(In reply to comment #3)
> LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\""
> vhost_combined

Ok, this makes clear that it isn't really a mod_ssl specific issue. %p is the
canonical port taken from server_rec's "port" field, which is populated from
the ServerName directive in core.c:server_hostname_port(). (If you want to log
the actual port of the current connection, use "%{local}p" in your LogFormat
string.)

Adding "ServerName space-station:83" will solve your issue, and as this is what
http://httpd.apache.org/docs/2.2/mod/core.html#servername is recommending ("For
optimal reliability and predictability, ..."), I'm closing this bug with
WONTFIX.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message