httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 52616] New: SSLUserName uses SSL_CLIENT_S_DN insted of SSL_CLIENT_S_DN_CN (or any x509)
Date Tue, 07 Feb 2012 06:14:59 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=52616

             Bug #: 52616
           Summary: SSLUserName uses SSL_CLIENT_S_DN insted of
                    SSL_CLIENT_S_DN_CN (or any x509)
           Product: Apache httpd-2
           Version: 2.2.16
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_ssl
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: m-one@mail.ru
    Classification: Unclassified


I've trouble using SSL_CLIENT_S_DN_CN in SSLUserName with FakeBasicAuth.

My apache config:

<Location /repos>
    SSLOptions +FakeBasicAuth +StdEnvVars
    SSLUserName SSL_CLIENT_S_DN_CN
    AuthName "Restricted area"
    AuthType Basic
    AuthUserFile /etc/apache2/fakeauth.passwd
    require valid-user
</Location>

In this case SSL_CLIENT_S_DN_CN equals SSL_CLIENT_S_DN. I've used patch
http://reki.ru/products/subversion/patch-server-ssl_engine_kernel.c which
correct this behaviour to the right way.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message