httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 51411] New: TLS Server Name Indication (SNI) isn't support on IPv6 connections
Date Tue, 21 Jun 2011 18:27:04 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=51411

             Bug #: 51411
           Summary: TLS Server Name Indication (SNI) isn't support on IPv6
                    connections
           Product: Apache httpd-2
           Version: 2.2.19
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_ssl
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: marc@moonscoop-fan.com
    Classification: Unclassified


Hello,

Apache HTTPD does not seam to support Server Name Indication when IPv6 is used,
it chosses the wrong certificate.

I noticed that on one of my website, that works correctly on IPv4 but fails on
IPv6 with the error : "Wrong site, the common name (CN) doesn't match".
(https://forum.generation-taraddicts.com/)

Don't hesitate to ask me if you need more information to solve this issue.

Thanks in advance !

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message