httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 51103] mod_reqtimeout does not drop connection and return 408
Date Tue, 26 Apr 2011 13:21:32 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=51103

guillaume.bilodeau@gmail.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|INVALID                     |

--- Comment #6 from guillaume.bilodeau@gmail.com 2011-04-26 09:21:30 EDT ---
(In reply to comment #4)
> (In reply to comment #3)
> But as you say, it does not show a 200 result code. I will mark this as invalid
> because for the other issues, there have already been different PRs. If you can
> reproduce the code 200 sent despite of a timeout issue, please change the
> status from INVALID to REOPENED.

Ok, I have reproduced the problem, although it's slightly different from what I
initially wrote.

You will see in the new attachment that the request times out but returns a 302
Redirect instead of a 400 Bad Request. A valid request should indeed return a
302 because of a RedirectMatch rule in the httpd-vhosts.conf file, but the
request times out and a 302 is returned anyway. Also, you will see that the
client keeps sending data after the connection is closed - although this may be
an issue with the http_dos_cli tool.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message