httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50954] New: ProxyRemote doesnt use CONNECT method with https scheme
Date Mon, 21 Mar 2011 13:48:39 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50954

           Summary: ProxyRemote doesnt use CONNECT method with https
                    scheme
           Product: Apache httpd-2
           Version: 2.2.17
          Platform: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_proxy
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: vgaprayer@gmail.com


IE -> apache proxy -> my program' custom proxy

Config string:
ProxyRemote * https://127.0.0.1:27015

ProxyRemote works, but my custom proxy(127.0.0.1:27015) receives "GET" request
from apache proxy, instead of "CONNECT" request as described in
http://httpd.apache.org/docs/current/mod/mod_proxy.html#proxyremote

I use http requests in IE, not a https, but manual dont says anything about
incoming scheme.

All related modules are normally loaded by apache
(proxy_module,proxy_connect_module,proxy_http_module)

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message