httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50914] New: "DirectoryIndex index" fail to work with +MultiViews options
Date Fri, 11 Mar 2011 06:02:40 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50914

           Summary: "DirectoryIndex index" fail to work with +MultiViews
                    options
           Product: Apache httpd-2
           Version: 2.2.9
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_negotiation
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: zhangweiwu@realss.com


Debian 5.0, apache 2 2.2.9-10. I've optioned multiviews, and it
works perfectly fine for every document except index page.

All site using URIs without file extension names, every URI map to 2
files. e.g. about_us have 2 corresponding files:

about_us.en.html
about_us.de.html

And accessing /about_us gets the right language according to browser
setting, works perfectly.

Problem being the index page shows up as a blank page. More tests shows:

                       Firefox       w3m          wget
http://mysite          blank page    blank page   English page
http://mysite/index    English page  English page English page

Expected behavior is http://mysite should not show non-blank page in any case,
if I understood the document right.


Here is related section of configuration

    <Directory /var/www/www.realss.com.cn/htdocs/>
        Options FollowSymLinks MultiViews +Includes
        DirectoryIndex index
        AllowOverride All
        Order allow,deny
        allow from all
        AddHandler server-parsed .shtml
        SSITimeFormat "%S"
        XBitHack on
        Header append Vary cookie 
    </Directory>

To workaround this issue, I have to replace "DirectoryIndex index" with:

    DirectoryIndex index.en.html


This breaks multviews on the index page of course. Removing execution bit of
the index.??.html files would not workaround this issue.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message