httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50873] New: httpd does not start properly when built from source with "with-mpm=worker" and ChrootDir directive
Date Fri, 04 Mar 2011 23:07:10 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50873

           Summary: httpd does not start properly when built from source
                    with "with-mpm=worker" and ChrootDir directive
           Product: Apache httpd-2
           Version: 2.2.17
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: worker
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: gajowniczek_m@yahoo.com


I built apache 2.2.17 [ubuntu 10.04] from source with intent to use:

- MPM "worker" instead of "prefork", I used configure switches:
--with-mpm=worker and --disable-prefork  

- apache built-in ChrootDir directive

After starting the httpd it seems the parent process starts ok but has problem
to create the child processes. The child processes are in [httpd] <defunct>
state, they go down and up, httpd does not serve any requests.

I observed also the following:
- When built apache with MPM prefork and used ChrootDir it works OK, all child
processes operate OK in jail. Parent process is operating out of jail.
- When build apache with MPM worker and did not use ChrootDir it works OK as
well, the same way as with MPM prefork and ChrootDir

Marcin

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message