httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50915] Program terminated with signal 4, Illegal instruction.
Date Fri, 11 Mar 2011 16:24:30 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50915

--- Comment #4 from joe <jhsusc@umd.edu> 2011-03-11 11:24:28 EST ---
Thank you, yes, we are planning for upgrade.
As those are in the current production environment, Just wondering is there any
other probable cause for the crash? as we have other Apache instances runs the
same library and works fine..

> You are using a very outdated version of httpd and evene older version of
> openssl.
> 
> The crash seems to happen here:
> Thread 16 (process 1143667    ):
> #0  0x00589670 in ?? ()
> 
> No symbol table info available.
> #1  0xff365de4 in ssl3_shutdown () from /dept/oit/eis/usr/lib/libssl.so.0.9.6
> No symbol table info available.
> #2  0xfe6dd2ec in SSL_smart_shutdown (ssl=0x83dc70) at ssl_util_ssl.c:188
>         i = 0
>         rc = 8641648
> #3  0xfe6cf23c in ssl_filter_io_shutdown (filter_ctx=0x35a2b8, c=0x359eb0,
> abortive=0) at ssl_engine_io.c:963
>         ssl = (SSL *) 0x83dc70
>         type = 0xfe6e17f8 "standard"
>         sslconn = (SSLConnRec *) 0x35a200
>         shutdown_type = 2
> 
> 
> Please try to update openssl and httpd to a recent version and check if the
> crash remains.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message