httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50562] wrong PATH_INFO CGI environment with non-ASCII UTF8 characters
Date Tue, 11 Jan 2011 11:25:21 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50562

lu ye <yelu27@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |VERIFIED
         Resolution|INVALID                     |REMIND

--- Comment #6 from lu ye <yelu27@gmail.com> 2011-01-11 06:25:16 EST ---
If and only if I use Unicode win api-GetEnvironmentVariableW that I can get the
right answer. C lib getenv and GetEnvironmentVariableA all returns wrong
answer. Use chcp to change codepage makes the result no difference.
I am puzzled. Which coding scheme is used by apache to set environ vars? What
happened when passing them to CGI and getting them in CGI?  
(In reply to comment #5)
> What does CHCP return at the command line?

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message