httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50508] New: mod_proxy_connection doesn't work over ssl connection
Date Tue, 21 Dec 2010 23:02:09 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50508

           Summary: mod_proxy_connection doesn't work over ssl connection
           Product: Apache httpd-2
           Version: 2.2.17
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_proxy
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: Evgeny.Sabelskiy@gmail.com


i have tested "CONNECT blablabla" request over TLS connection and found issue.

Apache 2.2.17, standard schema for VirtualHost:443

ProxyRequests on
ProxyVia on
AllowCONNECT 443

<Proxy *>
Order Deny,Allow
Deny from all
Allow from 127.0.0.1
</Proxy>


so, i want to allow CONNECT proxy on 443 port and want to proxy requests to
remote 443 hosts.

okay, apache gets my SSL secured request "CONNECT ....." w/o any problem, but
then sends me response "HTTP/1.0 200 Connection Established" using not secured
layer (seems just pushes text response to tcp stream), so, my client (Apache
Java HTTPClient) failed to parse SSL response.

it is easy to reproduce problem and capture "bad" response by tcpdump.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message