httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50454] New: configure fails when apr and apr-util are in different places
Date Fri, 10 Dec 2010 14:38:40 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50454

           Summary: configure fails when apr and apr-util are in different
                    places
           Product: Apache httpd-2
           Version: 2.2.17
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: minor
          Priority: P2
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: dylan@dylex.net


If apr and apr-util have been install with different prefixes (but are still
both in the path) such that, in particular, `apr-1-config --includedir` and
`apu-1-config --includedir` are different, configure reports:
  configure: error: APR-util version 1.2.0 or later is required
The underlying error is:
  apu_version.h:109:25: fatal error: apr_version.h: No such file or directory
Since apr-util depends on apr, configure should add apr's includes when
checking apr-util.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message