httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50283] New: configtest doesnt report error when modules arent enabled
Date Wed, 17 Nov 2010 06:43:29 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50283

           Summary: configtest doesnt report error when modules arent
                    enabled
           Product: Apache httpd-2
           Version: 2.2.8
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: ram_chander250@yahoo.com


Situation:
Below is .htaccess

AuthUserFile .htpasswd
AuthName "Authorization Required"
AuthType Basic
require valid-user
ExpiresActive on
ExpiresDefault "access plus 2 hours"

But "expires" module isnt enabled in the host, and therefore results in "500
Internal Server error" when url is accessed via browser.

However configtest gives OK
# apache2ctl configtest
Syntax OK

This should fail and if possible throw out which module isnt enabled. In other
words, configtest should parse and check if modules are enabled and throw out
appropriate failure message.

# apache2 -v
Server version: Apache/2.2.8 (Ubuntu)
Server built:   Jun 18 2010 11:04:08

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message