httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject DO NOT REPLY [Bug 50190] New: disable-maintainer-mode on OpenSuse 11.3 (gcc 4.5) causes POST failure
Date Mon, 01 Nov 2010 16:03:24 GMT

           Summary: disable-maintainer-mode on OpenSuse 11.3 (gcc 4.5)
                    causes POST failure
           Product: Apache httpd-2
           Version: 2.2.17
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Core

Compiling a minimal httpd 2.2.17 on OpenSuse 11.3 which uses gcc 4.5 causes all
HTTP POST requests to fail with an empty response and the following lines in

[crit] file http_filters.c, line 523, assertion "totalread >= 0" failed
[notice] child pid 27403 exit signal Aborted (6)

This failure does not occur on OpenSuse 11.2 or any other distro which I've
tested: Fedora 13, ScientificLinux 5.5, and Ubuntu Server 10.10. Note that
those working tested distros all use gcc 4.4
   Behaviour is similar for at least Apache 2.2.16 and 2.2.14.

Reproducable with:
1: ./configure --prefix=/usr/local/2217-no-maint --enable-cgi
2: make install
3: set ip address as ServerName, set cgi files to executable
4: start server
5: curl -d "item=abc" http://localhost/cgi-bin/test-cgi
6: result: curl: (52) Empty reply from server
7: test as a GET
8: curl http://localhost/cgi-bin/test-cgi?item=abc
9: result: expected environment variables displayed

Make it work by allowing maintainer mode
1: ./configure --prefix=/usr/local/2217-with-maint --enable-cgi
then POST tests work. Binary is ~2k larger.

Found a semi-related note at the bottom of this page: . But my build is
without any external modules.

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message