httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50061] New: Semicolon character '%3B' seems to be decoded to ';' too early.
Date Fri, 08 Oct 2010 14:57:43 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50061

           Summary: Semicolon character '%3B' seems to be decoded to ';'
                    too early.
           Product: Apache httpd-2
           Version: 2.2.14
          Platform: Other
        OS/Version: Linux
            Status: NEW
          Severity: minor
          Priority: P2
         Component: mod_proxy
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: david.goate@cognitran.com


We are using mod_proxy 2.2.14 on an Intel Linux box to proxy requests from
Apache to jBoss 5.01 via AJP.

Mod_proxy seems to be decoding the escaped semicolon character before passing
the request to jBoss.

E.g.
http://myhost/myapp/service/some%3Bpath -->
http://myhost/myapp/service/some;path

If we access jBoss directly without going through Apache the issue does not
occur.
http://myhost/myapp/service/some%3Bpath -->
http://myhost/myapp/service/some%3Bpath

I wondered if this was some regression as I have read similar comments in 2.2.6
that claimed that this was fixed in 2.2.7
(https://issues.apache.org/bugzilla/show_bug.cgi?id=43972)

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message